This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Andreas W. 1 month ago.

Assigned support staff: Andreas W..

Author Posts
September 9, 2019 at 11:13 am #4536421

matthieuV-4

Dear WPML team,

I'm using Woocommerce for my bookings on the website Samui Buddy.

Many of my emails are well translated regarding the language chosen from the customer. But some sentences are not translated, even if I can find them on my String Translation panel.

Could you please explain me why ?

Here are some screenshots to explain you the problem.

Looking forward to hear from you

Matthieu

September 9, 2019 at 5:25 pm #4539357

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Could you please go to Settings -> Permalinks and make sure that the default permalinks for prodcuts, product-tags and product-categories are set to English.

Then go to WooCommerce -> WooCommerce Multilingual -> Store URLs and make sure that all URLs are translated corrently. Avoid using the same names vor various slugs and always write the slugs in lowercase and connected with a dash symbol ("-") between seperated words.

If this will not solve the issue make sure that all plugins and the theme are up-to-date.

Also go to WooCommerce -> Status and check for Template files.
Those emails are based on WooCommerce and can sometimes be outdated. You will find more detailed information here if needed.

Let me know if you need further assistance.

Kind regards
Andreas

September 10, 2019 at 9:58 am #4543731

matthieuV-4

Hello Andreas,

Thank you for your help.

I've checked all your points, and it's still not working. Would you like an access to log in and to check ?

Cheers,

Matthieu

September 10, 2019 at 4:37 pm #4547333

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 12, 2019 at 5:03 pm #4563609

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I can see you are using Kadence WooCommerce Email Designer. It might be that we are handling with a compatiblity issue. Are the emails translated if you disable this plugin?

If not, could you please test if the emails are also not translated correctly if you disable any additional plugin and run the site only with WooCommerce and WPML and its add-ons?

The following plugin can help zou to catch emails and see them on the repsective WordPress Settings section under Emails Catch All.

https://wordpress.org/plugins/emails-catch-all/

Kind regards
Andreas

The topic ‘[Closed] Problems on email translation – Some sentences are not translated’ is closed to new replies.