If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Vincenzo 11 months ago.

Assigned support staff: Vincenzo.

Author Posts
December 16, 2018 at 5:10 pm #3005892

Dan

Dear support people,

I am trying to sync hidden link with our production site at hidden link
However I am getting errors "WPML is missing some records in the languages tables ... " - see the screenshot taken from hidden link.

Steps to sync:
1. on hidden link : wp db export ~/production-db.sql
2. on hidden link : wp db import ~/production-db.sql
3. rsync hidden link to dev3.internetsociety.org/wp-content/uploads
4. rsync hidden link to dev3.internetsociety.org/wp-content/languages

Obviously something is still not identical to get this working. We had this in the past and usually, if database and files are well synced, the problem goes away.

Do you have any idea if we missed any other files to sync? Any other idea you could provide?
Thanks much for your precious help!
Please respond to wohlfarth@isoc.org as this account is linked do my colleague's e-mail address.
Henri Wohlfarth (not Dan)
Internet Society Develop

December 17, 2018 at 12:14 pm #3007991

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, thank you for contacting WPML Support!

The errors shown in the screenshots are probably caused by corruption in the WPML database tables.

1. Can you please tell me if your sync procedure worked correctly in the past?

2. Are the production and dev SQL servers and/or database different in any way (eg. different version, different collation, etc)?

3. Are the WordPress or the plugins versions different in any way?

4. Can you please try again the migration by using Duplicator or WP Migrate DB plugins?
- https://toolset.com/faq/how-do-i-migrate-a-wordpress-site-from-one-domain-to-the-other/

Thank you

The topic ‘[Closed] Problems to sync Development site with Production site’ is closed to new replies.