This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Problem with using custom link (anchor) in menus

Solution: - Go to Appereance->Menus - on custom, link menus use the full link instead of just #id for example instead of "/#vettehaak" use "https://example.com/#vettehaak" - Synchronize the menu and make changes in secondary languages accordingly.

This topic contains 7 replies, has 2 voices.

Last updated by johanK-5 12 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 22, 2018 at 3:28 pm #2838652

johanK-5

URL: hidden link

I have problems with anchors within the same website to another page.
In the Dutch version I can go back to the 'DE COLLECTION' via 'DEALERS'. This is not possible in the German translation. Also the link to 'CHARACTER' can not be accessed from 'DEALERS'. I have created anchors in the same way but in one way or another they do not work within the German pages. Thank you in advance for the help!

October 23, 2018 at 9:31 am #2841690

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could you please provide me with further information regarding this? Can you attach a few screenshots showing the issue?

Look forward to your reply.

Thanks

October 23, 2018 at 10:07 am #2841761

johanK-5

Hi Shekhar,
When I am visiting the German site > HÄNDLER, i can't go from there to 'CHARAKTER' or 'DIE SAMMLUNG'. It has something to do with wrong URL's ... i think.
In the Dutch version all the buttons and anchors work allright. Anchors were made exactly the same. Hope you can help 😉

October 23, 2018 at 10:56 am #2841896

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see the issue, how are you adding these menus, would you mind if I check your settings once, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

October 24, 2018 at 9:03 am #2845450

johanK-5

Hi Shekhar,
We made up an staging link; so you can work without any problems what so ever.
How can we send you the login info?

The link you send me (hidden link) is a static one. I can't fill-in the info ...

Thanks in advance.

Regards,
Johan Koch

October 24, 2018 at 9:10 am #2845539

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have enabled the private reply for the next reply, so on the next reply, you can send those details to me.

Look forward to your reply.

Thanks

October 24, 2018 at 11:07 am #2845884

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please follow the below steps to fix the issue:
- Go to Appereance->Menus
- on custom, link menus use the full link instead of just #id for example instead of "/#vettehaak" use "hidden link"
- Synchronize the menu and make changes in secondary languages accordingly.

Let me know if this helps.

Thanks

October 24, 2018 at 12:53 pm #2846247

johanK-5

My issue is resolved now. Thank you!