This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by Andrés 3 years, 1 month ago.

Assigned support staff: Andrés.

Author Posts
August 10, 2016 at 4:44 pm #998359

marcH-8

Hi Andrés,

you helped me a lot with the last problem where I clicked the "show only products with custom prices in secondary currencies".

Now I have another problem, that's why I opened a new ticket. I am not sure if it's wpml multilingual related or plugin related. I have set up all currencies at the wpml multilingual - multi-currencies.
I also set up the plugin I am using (WooCommerce Currency Switcher v.2.1.6).
It works, but it behaves strange.
See it at:
hidden link

There is a price of 9 € shown. First of all, GBP is the default currency for English, so I wonder why there is Euro shown. Then, I set a price of 9,50 Euro. This should be 8 something GBP. I set it to round to the next 1 integer, so I guess the 9 euro is the round up. But it should be GBP !! Not Euro! Check the currency switcher on the page, it has always a € sign in front of GBP, CHF + USD.
If you change to German it shows 9,50 €, which is correct. So, I guess there is something mixed up between the plugin and the multi-currency of wpml multilingual.
Besides the fact that in the currency switcher in the top nav bar it shows "CHF CHF" and not the currency sign.
AND... when I update the settings of wpml multlingual - multi-currencies, it saves FOREVER and doesn't stop!!
I mean this setting:
hidden link

So, what do you think it could be? thanks.

August 11, 2016 at 7:15 am #998918

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Marc,

Welcome back!

If I understand correctly, you are using our WooCommerce Multilingual Language switcher and "WooCommerce Currency Switcher" and probably this is not a good idea as it can creates some incompatibilities having two different plugins for the same objective.

Let's check if there is an error :

1. It would be good if you can provide me the WordPress debug.log (not WPML debug informations). Please check this page for instructions
https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion).

Let's see if there is a compatibility with your plugin or others:

2. Please check if this issue appears when:
- All non WPML Plugins are disabled (except for WooCommerce). It will tell us if there is an interaction issue with other plugin.
- Theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

I'll wait for your comments.

Best regards,
Andrés

August 11, 2016 at 8:36 am #999014

marcH-8

Hi Andrés,

regarding the debug.log, we have done this some days ago. Since the problem is for weeks, the result would be the same. The debug.log some days ago showed only 1 error, related to the table-rate-shipping plugin, which is:

[08-Aug-2016 18:15:55 UTC] PHP Strict Standards:  Declaration of MH_Table_Rate_Plus_Shipping_Method::calculate_shipping() should be compatible with WC_Shipping_Method::calculate_shipping($package = Array) in /var/www/vhosts/quattromori.store/httpdocs/wp-content/plugins/mh-woocommerce-table-rate-shipping-plus/mh-wc-table-rate-plus.php on line 55

Since deactivating all plugins and then activating one-by-one takes some time, I'll have to do this tomorrow.
however, you are correct, I am using the language switcher AND currency switcher, but I see a lot of sites that have both, a language switcher and a currency switcher.
In the meantime I will also contact the author of the plugin and ask him as well.

thanks and have a nice day,
marc

August 11, 2016 at 11:26 am #999360

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Marc,

I completely understand now, I though it was a new situation. Please, take your time, I'll be happy to continue investigating this situation.

Regards,
Andrés

August 13, 2016 at 10:49 am #1002011

marcH-8

Hi Andrés,
I disabled the "woocoommerce currency switcher plugin" and then the calculation and the prices in GBP work perfectly. No problems then.
BUT.. of course I don't have this nice currency switcher in my top navigation menue. I added the shortcode

[currency_switcher]

to my menu, but I don't really like the design of the currency switcher.
If I could:
- specify the position of the switcher (right now it's before the language switcher)
- add some flags
- adjust css/colors etc.
then it would be fine.
Otherwise I would like to use the woocommerce currency switcher plugin. BUT then I have this incompatibility issue with wpml woocommerce multlingual!!
Any idea how this incompatibility could be resolved? So I could both, the plugin and wpml multi-currency?

thanks and have a nice weekend!
marc

August 13, 2016 at 3:46 pm #1002078

marcH-8

Hi Andrès,

so, I deactivated the woocoommerce currency switcher plugin and put some css code for the wpml currency switcher so that it appears in the top navigation as I wanted to. There is no mouseover as for the language switcher, right?!
And there is no option to add flags, right?!
I am fine so far with the design of the currency switcher though. But maybe you still could check the incompatibility of wpml multilingual multi-currency and the "woocoommerce currency switcher plugin". It's this:
hidden link
I had bought the plugin.

Thanks for your help!
marc

August 15, 2016 at 7:20 am #1002556

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Marc,

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue. Could you please indicate me how to replicate this behaviour?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!
You can use a plugin for this if you like. You can use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Regards

August 24, 2016 at 3:56 pm #1020021

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Marc,

I've visited your site and I could switch currencies from the currency selector placed on the top bar. Could you please describe me how to reproduce this behaviour ?

On the other hand, could you please upgrade:
- WPML Multilingual CMS
- WPML String Translation

Regards,
Andés

August 24, 2016 at 7:55 pm #1020295

marcH-8

Hi Andrès,

very strange. For me it doesn't work, neither with Chrome nor Firefox (latest versions). With Edge it worked only once (changing from GBP to CHF), but then I wanted to change to USD and it didn't work. Please see a video of trying to change the currency (with Chrome on Windows): hidden link

I have also updated the plugins. There was no message to update them on the dashboard/menue as I am used to....

thanks, marc

August 25, 2016 at 7:14 am #1020813

marcH-8

Hi Andrès,

I saw you disactivated the plugins (I guess it was you). All but the woocommerce and wpml. However, to show the site you need more plugins, such as the visual composer and the ones that are theme dependant. Otherwise the site doesn't display!
Further more, the disactivation of the plugin can take only some minutes, because this is a working site and I have adwords ads running for this site. I don't want to show customers a blank or not working site.
I will now activate all theme dependant plugins and the visual composer, but later on I have to activate all, because the site must work for my customers.
thanks, marc

August 25, 2016 at 7:40 am #1020855

marcH-8

sorry to say, but deactivating and activating my plugins broke my site a bit. Many customizations are gone and other things have to be configured again. I don't know why. But I think it's best to leave the site as it is right now, because the broken site makes me more headaches than the not properly working currency switcher...
Thanks for your effort!!!
Or maybe you have found something?
thanks, marc

August 25, 2016 at 7:44 am #1020858

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Marc,

Sorry about that, I thought I was working on a test site as requested.

So far I have had a lot of '500 Internal Server Error' errors, and I have moved slow for the same reason. It seems like you have some server resource issues.

I see that the Currency switcher from the products page works fine. However, it is not the case for the one on the home page, I could replicated this time.

When I deactivate all your plugins, this currency switcher disappeared. Could you please tell me how have you added? Which files/section have been modified for it?

On the other hand, I have installed Duplicator plugin but I wasn't able to create a snapshot for some server restrictions.

At this moment I'm trying to create a copy with All-in-one WP Migration but it hasn't finished yet (crossing fingers).

I haven't found anything concrete so far, between the constant Internal Server Errors and knowing that it is a production site, I need to continue locally.

Regards,
Andrés

August 25, 2016 at 8:14 am #1020915

marcH-8

Hi Andrès, first of all, thanks for your continous effort!! Yes, it's a production site and I made of course backups, but still I don't have a clue why some customizations disappear when deactivating/activating the plugins. This happened also before and that's the reason why I am always concerned about deactivating all plugins for testing-purposes.
The footer has lost some widgets. I have screenshots of my site and know which widgets, but still, how come it's loosing them. And also some blocks on the left bar are missing. It could be a permission issue on the server, I am not sure.

Regarding the 500-error: I KNOW!!! terrible!! I have this ongoing for 2 weeks now. I have created a new .htacces and the php settings are all high enough. I will get a tech guy who checks the server. I have a lot of "connection lost" and Server errors.

Currency switcher: I have just added it by the wpml woocommerce multilingual currency options. Then a tech guy added some CSS to fit it perfectly in the top nav bar. It's under: Appearance - Theme Options - Skin - Custom CSS

thanks,marc

August 25, 2016 at 8:15 am #1020917

marcH-8

Hi Andrès, first of all, thanks for your continous effort!! Yes, it's a production site and I made of course backups, but still I don't have a clue why some customizations disappear when deactivating/activating the plugins. This happened also before and that's the reason why I am always concerned about deactivating all plugins for testing-purposes.
The footer has lost some widgets. I have screenshots of my site and know which widgets, but still, how come it's loosing them. And also some blocks on the left bar are missing. It could be a permission issue on the server, I am not sure.

Regarding the 500-error: I KNOW!!! terrible!! I have this ongoing for 2 weeks now. I have created a new .htacces and the php settings are all high enough. I will get a tech guy who checks the server. I have a lot of "connection lost" and Server errors.

Currency switcher: I have just added it by the wpml woocommerce multilingual currency options. Then a tech guy added some CSS to fit it perfectly in the top nav bar. It's under: Appearance - Theme Options - Skin - Custom CSS

thanks,marc

p.s.: is there a way to get rid of these annoying notices for each plugin "Do you want to scan for translatable strings in the plugin(s)?" ???? Even if I click them away, they appear again...

August 25, 2016 at 8:52 am #1020984

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thank you Marc, but it hasn't been possible to crete a copy of your site. Could you please tell me if you add a Shortcode or a PHP function to add it and where?

About the messages, as a workaround you can delete the key wpml_notices in wp_options table. Does it help?

Regards