This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The posts in the "Recent Posts" widget were linking to the same (wrong) link, no matter on which one you were clicking (the normal behavior is that each post should go to its own link).

Solution:

The Cornerstone support team said that their plugin is compatible only with WPML 4.2.5 at the moment (our latest version is 4.2.6 at the moment - 23 may 2019) and offered a solution to the client:

- Edit the file "wp-content/plugins/cornerstone/includes/classes/components/class-wpml.php"
- Disable this line:

add_filter( 'the_permalink', array( $this, 'filter_permalink' ) );

- Save the changes.

This topic contains 6 replies, has 2 voices.

Last updated by anniT-2 4 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 17, 2019 at 3:03 pm #3835469

anniT-2

Tell us what you are trying to do? If you go my page: hidden link and click recent post, you can see that all the headlines go to the same article.

I have already talked with the theme provider. I have tested that WPML multilangual CMS causes the problem. They told me that they support only version 4.2.5. and I have already 4.2.6. Can I somehow go back to the older version?

Or do you have better solution how to get this work?

Thank you!

May 17, 2019 at 3:51 pm #3835805

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. You can try these steps to see what is causing the issue:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

This will help you to see if the issue is caused by the theme or not.

2. If it's a theme issue as the developers of the theme that you are using say, then you can go to the link below and download an older version like WPML 4.2.5:

https://wpml.org/download/wpml-multilingual-cms/?section=changelog

After that:

1. Create a full backup of the current site
2. Disable the WPML plugin
3. Delete the WPML plugin
4. Install/upload the new WPML plugin
5. Activate WPML

Those are practically the steps to manually download and install WPML.

Here you can find more info about this process:
https://wpml.org/faq/install-wpml/#updating-manually

I hope that this information helped.

Please let me know how that goes.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week in case you have more questions about this matter.

Kind regards,
Mihai Apetrei

May 20, 2019 at 12:04 pm #3846613

anniT-2

Hi! It seems that actually it is the Cornerstone that causes the problem. Not the theme. So, do you think it is better to activate the version 4.2.5 still? Or what I should do?

May 20, 2019 at 5:48 pm #3849441

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

If Cornerstone is confirmed to be the issue and you still need to use it, I do recommend to make a full backup and downgrade to WPML 4.2.5.

I would also ask the developers of the Cornerstone plugin to let you know when the plugin becomes fully-compatible with the latest version of WPML so that you can update back.

I hope that you will find this information helpful. 🙂

Kind regards,
Mihai

May 21, 2019 at 2:59 pm #3856433

anniT-2

Hi! I did that! But is not helping at all. I have the old version installed but the problem still exists. I will contact their support at this point again.

May 22, 2019 at 9:03 am #3863369

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you very much for updating me!

Please let me know how it's going and what they respond back.

Also, if they manage to offer you a solution, it would be really helpful if you can share it here, too, as some other people who might experience the same issue could benefit out of that.

I will be waiting for your response.

Kind regards,
Mihai

May 23, 2019 at 7:45 am #3872127

anniT-2

I fixed that with this:

Edit the file wp-content/plugins/cornerstone/includes/classes/components/class-wpml.php
Disable this line:
add_filter( 'the_permalink', array( $this, 'filter_permalink' ) );
- Save the changes.