This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Dat Hoang 5 years, 10 months ago.

Assigned support staff: Dat Hoang.

Author Posts
December 4, 2013 at 10:38 pm #302541

Olari

Hi, I have problems with the following site:

hidden link

When changing language to russian, then the shopping cart link still directs to default language, altough there is a translation of it in russian. Same deal with my account link "Minu kasutaja." Also has a translation, but directs to default lang.

Second problem also in russian language. When logged out and trying to register("Registreeri") or recover password("Unustasin parooli") it gives Error 404 - page not found.

If I could get some help please 🙂

December 5, 2013 at 7:56 am #302628

Dat Hoang
This answer solved user's issue.

Hello,

#1,
Make sure you are using latest version of WPML and its add-ons.
+ WPML Multilingual CMS 3.0.1
+ WPML String Translation 2.0.1
+ WPML Translation Management 1.9.1
+ WPML Media 2.1.1
+ WooCommerce Multilingual: 3.0.1
Check and download: http://wpml.org/my-account/downloads/

#2,
Please try WPML->Support-> Troubleshooting – > 'General clean up' / 'Set language information' / 'Fix terms count' / 'Remove ghost entries from the translation tables'

Let me know how is your problem?

Thanks.

December 5, 2013 at 8:04 am #302633

Olari

I have done all this, problem still exists. Tried also updating permalink and rescanning strings.

December 5, 2013 at 9:17 am #302694

Olari

Edit:

I put older versions back, because then Sensei didn't work. Anyway updates didn't help.

December 6, 2013 at 6:17 am #303229

Dat Hoang

Hello,

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply.

Note that:
+ Backup your site before giving us your credentials
+ It would be better if you give me the test site rather than live site.

Thank you!

December 6, 2013 at 10:48 am #303372

Olari

Hi, I provided the needed info for our testsite.

December 9, 2013 at 4:06 am #304150

Dat Hoang

Hello,

Thank you for your info.

As I see in WPML -> Support, you are using the old versions of WPML and its add-ons.
Please check in http://wpml.org/my-account/downloads/ and make sure they are up-to-date.

Thanks.

December 9, 2013 at 11:17 am #304344

Olari

As I said before, the updates didn't help and also Sensei plugin don't work then because of customizations there.

December 10, 2013 at 12:55 am #304685

Dat Hoang

Hello,

I'm sorry for misunderstanding.
I need to clarify something more:

1, Where do I get/buy Sensei plugin.?

2, What do you mean 'customization' in the previous reply?

3, As I understand your site is not new, and it worked before? So what did you do make it stop working correctly?

Thank you.

December 10, 2013 at 9:14 am #304829

Olari

hidden link - Sensei plugin

I meant that it is not with default settings and code, it have been edited to our needs.
No this russian errors what I described didn't work before also.

December 11, 2013 at 3:50 am #305443

Dat Hoang

Hello,

#1,
For the problem http://wpml.org/forums/topic/problems-with-second-language/#post-302541
The reason is that you have not translated products and checkout/cart pages of WooCommerce. Please translate them, and it will display in your site.

We have WooCommerce with WPML http://wordpress.org/plugins/woocommerce-multilingual/

Make sure you backup your site before installing any new thing.

If your problem persists, please install newest versions of WPML and its add-ons. We only support with the latest versions of our products.

#2,
For your case Sensei plugin, if you get any problem about working with WPML, please open a new thread for it.

Thanks.

December 14, 2013 at 1:56 pm #308388

Olari

But I have translated these pages already before you told me I havent and problems exists.

December 16, 2013 at 3:56 am #308668

Dat Hoang

Hello,

I'm sorry for the delay due to the weekend.
As I said on the previous reply, if your problem persists, please update your site with latest versions of WPML.

In your case, please update WPML and its addons, and let us know. Then, I will continue to help you.

Note: always backup your site.

Thank you.

December 17, 2013 at 10:00 pm #309919

Olari

Hi I have updated all plugins to latest versions, problem still exists.

December 18, 2013 at 8:46 am #310077

Dat Hoang

Hello,

1,
Please duplicate/create translations for all pages in hidden link . As you see in my attachment, you are missing many pages.

2,
For WooCommerce, we recommend you use WooCommerce Multilingual http://wordpress.org/plugins/woocommerce-multilingual/ . This plugin also helps you finish #1 easier.

Thanks.

The topic ‘[Closed] Problems with second language’ is closed to new replies.