Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by simonP-14 1 year, 7 months ago.

Assigned support staff: Lauren.

Author Posts
April 22, 2019 at 9:39 am #3654949

simonP-14

I am trying to: Translate Read more and next button with string translation, but it is not working...

Link to a page where the issue can be seen: hidden link

I expected to see: written "Več"
Instead, I got: "READ MORE"

On String translation to me it looks normal...

Thanks

April 22, 2019 at 12:53 pm #3655765

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Can you please tell me how the Read More button is created? Is it a button that you create within the page, or perhaps an option in the Theme Options for what text to have there?

If it is a theme option, the string may be stored in the admin texts. Can you please go to WPML > String Translation and scroll down to the bottom of the page and click on the link "Translate texts in admin screens »". Then, scroll through that page and see if you find the the string. If so, tick the checkbox and click Apply to add it to the String Translation table. Now you can go back to WPML > String Translation and you should see the string added there.

April 23, 2019 at 7:40 am #3660153

simonP-14

Hi Lauren,
I have checked the admin screens, but I can't seem to find the "read more" string.

April 23, 2019 at 4:46 pm #3666313

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

April 24, 2019 at 2:12 pm #3673813

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I think this may be a conflict issue with your theme. I don't see the Toranj theme on our list of compatible themes: https://wpml.org/documentation/theme-compatibility/

To confirm this, please try temporarily switching to minimal settings. Disable non WPML plugins and switch to a default theme such as Twenty Nineteen (be sure to make a full backup of your site first). Then, see if you are able to translate the default theme Read More strings. If so, switch back to your main theme and check again to see if the string is translated.

Please let me know the results of this test.

April 24, 2019 at 2:35 pm #3674177

simonP-14

Hi,
at the moment I cannot switch the theme (maybe during holidays), but we also have almost the same site for our vienna gallery... there the translation works fine...
hidden link
If you want I can give you access to that website too...

April 24, 2019 at 7:39 pm #3676495

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Is your other site using the exact same theme? I can set up a copy of your site locally and test.

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

April 29, 2019 at 1:33 pm #3703787

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hi Simon, I found that you have String Translation disabled in WPML -> Theme and plugin localization. This is why the Read More translation is not showing. To confirm, I temporarily activated String Translation and I could then see the translation. Please see attached screenshot.

I switched it back to your settings, but in order to see the string translations, just select one of the options to load string translation in WPML -> Theme and plugin localization and this will resolve the issue.

Please let me know if you need any further assistance and I will be happy to help.

April 29, 2019 at 4:17 pm #3705319

simonP-14

Ok, strange. Sorry about this, but I was sure it's on...
It was a bit strange that string translation was translating the contact details under the menu, even if it was turned off... the screenshots are before I turned it on...

Anyway, I am happy this is solved 🙂

Can you maybe also let me know how can I fix the uneven spacing in language switcher? Thanks

April 29, 2019 at 4:31 pm #3705611

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Glad I could help to resolve it. As the original issue is resolved may I kindly ask you please to open a new ticket for this question?
This will also help other users with similar problems find solutions when searching the forum as well as we avoid mixing lots of questions in one ticket.

Thank you for your understanding.

April 29, 2019 at 4:32 pm #3705617

simonP-14

My issue is resolved now. Thank you!