This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am using the BookYourTravel WordPress theme and I am not able to translate widgets.

Solution:

Please follow the procedure I mentioned in the link below: https://wpml.org/forums/topic/problems-with-widget-translations-2/#post-4134737

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

This topic contains 13 replies, has 2 voices.

Last updated by hectorV-3 3 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
June 23, 2019 at 2:51 am #4072207

hectorV-3

I am trying to: Translating a widget

Link to a page where the issue can be seen:

I expected to see:Widget string's translated

Instead, I got:They do not appear translated

June 23, 2019 at 3:01 am #4072285

hectorV-3

In order to have additional information, I tell you that I have carefully read the documentation on this subject and performed the steps as indicated. The final result is not what was expected.
The documentation that I have reviewed is the one found here https://wpml.org/documentation/getting-started-guide/string-translation/.
The solution I would like is not to have a widget for each language. This widget is part of the template book your travel and is the one that guarantees the search functionalities (Bookyourtravel Search Widget)

June 24, 2019 at 10:47 am #4076695

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I appreciate that you were able to offer extra info about the steps you already followed.

From what I can see, the theme that you are using is not part of our official WPML-compatible directory here (https://wpml.org/documentation/theme-compatibility/) but I would be more than happy to take a look and see if there's any way I can find to translate that widget.

1. Can you please tell me what is the exact name of the widget that you would like to translate and if you have it displayed on any page of your site (add link please, if you have)

2. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

3. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

June 26, 2019 at 1:21 pm #4092777

hectorV-3

Besides the problem to translate the widget, yesterday update the WPML plugins and now I do not have any translated string, please help me solve all these problems

June 26, 2019 at 3:20 pm #4093575

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I tried to log in but I receive an error when I try to access the wp-admin panel (attaching screenshot)

Can you please check?

Also, from my understanding, there is also a different issue happening.

In our forum, we try to keep one issue per ticket.


Continuing with one issue per ticket helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster so may I kindly ask you to please open a new ticket for the additional issue?

Thank you for your understanding.

I will be waiting for an answer from you regarding the login situation.

Kind regards,
Mihai Apetrei

June 26, 2019 at 4:17 pm #4094041

hectorV-3

Please try again, we are presenting some optimization problems on our site that are in the process of being resolved. I agree that it must be a new ticket, I simply considered it appropriate to mention it because both problems could be related

June 27, 2019 at 3:29 pm #4101297

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

From what I can see, the theme is requiring at least 48929 max input vars and this might be the issue for which the translation does not appear.

Can you please increase MaxInputVars to 50000 or more. For this, please try to set this variables in your php.ini:

max_input_vars = 50000;
suhosin.post.max_vars = 50000;
suhosin.request.max_vars = 50000;

You may need to contact your hosting provider to set them.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

Please let me know if that made the strings show up.

I will be waiting for your response.

Kind regards,
Mihai

June 28, 2019 at 8:08 pm #4110103

hectorV-3

Ok, the parameters in the file .user.ini have already been updated, what would be the next step to solve the problem? We hope as always for your kind help, thank you

July 1, 2019 at 6:03 pm #4121563

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

At the moment, it seems there is a different issue and it is not allowing me to access the site.

Can you please take a look?

Please let me know when that's solved.

I will be waiting for your response.

Kind regards,
Mihai

July 1, 2019 at 7:53 pm #4122049

hectorV-3

We do not have any problem that prevents you from accessing the site, please we need more detail to be able to determine why you can not access. Try again and let us know

July 2, 2019 at 2:33 pm #4127943

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

It is very weird, yesterday I was not even able to access your site (I was seeing the error in the screenshot that I attached in my reply from yesterday).

Today, I am able to access the site and the wp-admin login panel but when I introduce the credentials that you gave me a few days ago, I get the error that you can see in the new screenshot I attached below.

Do you know if the username or password has been changed?

Please let me know.

Kind regards,
Mihai

July 2, 2019 at 2:52 pm #4128165

hectorV-3

Sorry, please try again with the new credentials

July 3, 2019 at 10:25 am #4134737

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

I spent a good amount of time on the site, I was also able to see the strings you introduced but by checking a few online resources from the developers of the theme (and I will add some links below) it seems things work differently when you want to translate widgets from this theme.

They say that for translating the widgets, you would practically need to use the procedure from here (so instead of using the String Translation functionality, you will need to practically translate the words straight inside the widget):
- https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

So here is what I did:

- I logged into your WordPress admin panel and went to Widgets
- I found the "Hero Sidebar" widget position and I created a new "Book Your Travel: Search" widget element under the existing one
- I went to the already created widget element and at the very bottom, I selected the option to have that show only on English, then I saved
- For the other new "Book Your Travel: Search" widget element that I have created underneath the existing one, I scrolled down and selected it to show only on the Spanish language

Now, what I would need you to do is go to the second widget element I created (the one that is set to show only on Spanish) and please go through each of the widget tabs and translate everything into Spanish, then save.

That should be all you would need (I will also attach some screenshots that I hope will make your life easier and help you to understand what I mean).

If that's not enough, I can also screen record something for you, in case things are still not clear.

Please let me know how that goes.

Also, here are the links I told you about where I found that the developers of this theme recommend this procedure:

- hidden link
- hidden link

As I said, I already created a new widget for you for the hero position, following the steps above so you would practically need to do the same thing for each of the widget positions where you want to show the search bar - after you translate the Spanish one, for making things faster, I would recommend that you use a plugin that allows you to duplicate widgets (find out more here: hidden link).

I hope that you will find this information helpful 🙂

Kind regards,
Mihai

July 5, 2019 at 12:40 pm #4151379

hectorV-3

My issue is resolved now. Thank you!