Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 3 voices.

Last updated by svenG-16 11 hours, 30 minutes ago.

Assigned support staff: Alejandro.

Author Posts
November 9, 2019 at 2:46 pm #4918333

svenG-16

I am trying to: Edit pages in German via Cornerstone

Link to a page where the issue can be seen: The issues is inside the Cornerstone editor, there is no direct link.

I expected to see: The Cornerstone page where I would normally be able to edit my content

Instead, I got: "The preview could not load. This is most often related to a plugin conflict or aggressive caching. Checking the developer console for errors could indicate what went wrong."

I have installed no new plugins, the problem I believe is since the last update of the WPML Plugin. Editing with Cornerstone for the German pages was possible before. Now this problem is on every German page. I can freely edit anything on the English side, but when it comes to the German translations, nothing works.
Please advise what I should do.

Kind regards,
Sven

November 11, 2019 at 8:53 am #4922687

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Sven,

Thank you for contacting WPML Support.

Please check the following posts from the Theme author's forum:

#1 hidden link
#2 This answer is related to your language setting as a parameter. Please change it to the folder option:
hidden link

You will find the setting in WPML -> Languages https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Best Marcel

If you have any questions, feel free to contact me.

Best Marcel

November 11, 2019 at 7:55 pm #4927757

svenG-16

Hi Marcel,

And thanks for the reply.

I think I see what the issue is.
When I use this option:

Language name added as a parameter (hidden link - German)

it seems Cornerstone cannot work.
The problem is that when I go to the right place to change the settings I see this (Second screenshot).

I am not sure how to resolve this. I was using Polylang before and use a plugin to migrate all the already translated content to WPML. Is it possible that that is the issue?

Kind regards,
Julian

November 11, 2019 at 8:13 pm #4928007

svenG-16

I also just saw that I have URL rewrite enabled in the .htaccess file.

The folder structure is

root/public_html and inside it all the relevant files.

All seems correct to me, but it says there is an issue when I try "Different languages in directories".

Please advise.

November 12, 2019 at 10:50 am #4930847

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Julian,

exactly, this is the issue the user on the theme.co forum mentioned. For this, I linked directly to this answer in #2.

Did you check if your .htaccess is writeable? Another approach could be to ask your hoster to check the rewrite. Maybe it's blocked on your .htaccess. We have an example text for it here:

https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

Best Marcel

November 12, 2019 at 9:11 pm #4934919

svenG-16

Hi Marcel,

I as mentioned in my third post above, I have URL rewrite enabled in the .htaccess file.

This is already there:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

In any case, my business partner has enabled the option "Different languages in directories" already today despite the warnings. At first glance all seems to work properly and the editing inside Cornerstone is operational as well.

Is there a way to verify that we didn't break anything? What could we have broken with the move to enable this option without resolving the comments in red?

Best,
Julian

November 13, 2019 at 8:56 am #4936467

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Julian,

yes, I noticed that you activated your redirect, I meant that maybe the hoster let you save it, but the changes are not active. I see you are using GoDaddy, there a known for blocking functions. To be 100% clear I would recommend contacting your hoster and let them check the same as described here:

Please check this: https://wpml.org/forums/topic/language-url-problem-it-looks-like-languages-per-directories-will-not-function/

There is nothing that can get broken. Only the server is not well configured to use this option.

Best Marcel

November 14, 2019 at 9:18 pm #4950105

svenG-16

Hi Marcel,

So a couple of things. I am using GoDaddy only as a domain registrar, my hosting is ecoWebHosting. In any case I wrote to support there to see what they say.

I checked my phpMyAdmin settings as specified by the URL you sent. Settings seem to be in order as you can see in the first screenshot.

I also upload 2 pictures of my folder structure. FolderStructure1 is on root level and FolderStructure2 is inside my public_html folder.

Do you see any issues here? Maybe I'm missing something.

I am also sending the end of the .htaccess file. The code snippet is there.

Any other suggestions? We are not able to edit/translate new pages at the moment. That happened after changing the settings to "Different languages in directories".

Kind regards,
Julian

November 15, 2019 at 8:07 am #4951675

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Julian,

Looks everything OK. Let's see what the hoster says.

If you are worried, I can create an instance on Cloudways to test if it's working on another hosting environment. Please let me know.

Best Marcel

November 18, 2019 at 6:26 pm #4967273

svenG-16

Hi Marcel,

So the issue still persists. The guys from the hosting returned this:

"I have checked the link and I can see that you do have values in the home and siteurl section in the DB. Do they have any other suggestions on what needs to be done to get this working?"

Can you do some further testing to see if it's working on another hosting environment? I don't know what the issue is anymore.

Kind regards,
Julian

November 24, 2019 at 1:54 pm #5006773

svenG-16

Hi Marcel,

Thanks for the info and sorry for the late reply. Having a bad case of bronchitis at the moment and am on antibiotics.

So I just tried migrating everything, but for some reason the migration failed. There was no real explanation actually. I have uploaded an image of the email I received.

I am also guessing that the SFTP password that you gave me expires after the first try because when I try the migration one more time it says that the credentials are incorrect. How can we try migrating again? How should we proceed?

Kind regards,
Julian

November 24, 2019 at 2:10 pm #5006833

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Julian,

the FTP credentials are not expiring. I checked them and they are working (You can try with your FTP client. Could you please try it again?

Please note, that on the PW the first letter is a capital letter.

And get well soon 🙂

Regards
Marcel

November 25, 2019 at 12:17 pm #5011839

svenG-16

Hi Marcel,

Just tried again, but the result is the same. For some reason the migration fails. I am not sure how to proceed from here...

Kind regards,
Julian

November 25, 2019 at 12:18 pm #5011865

svenG-16

The migration fails at the last part when it's trying to migrate the DB tables. The same happened yesterday.

November 25, 2019 at 2:58 pm #5014849

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Julian,

should I try to run the migration from your site? Then maybe I can contact the Cloudways support if I see it live happen.

For this I would need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Please let me know.

Best Marcel