This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Radu 3 weeks, 6 days ago.

Assigned support staff: Radu.

Author Posts
September 7, 2019 at 12:57 am #4527693

martinaB-12

I am trying to: display the same template also in Italian version, but it doesn't work. Can you help me?

September 9, 2019 at 12:22 am #4532659

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Martina,

Thank you for reaching out the WPML support!

I just checked your website and I could see that there's a maintenance mode on it so I couldn't check the products archive. Is there any chance that you could give me access to the dashboard area so I can check this out (and the settings too), please?

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

September 11, 2019 at 9:57 am #4552331

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Martina,

Can you tell me if you made any other change, other than assigning this template to product archives and categories? I'm asking this because I was able to set the Italian template to be displayed on the same conditions (hidden link) but when I check an Italian category, the template is not applied. Can you have a look at this too, please?

Thanks,
Radu

September 12, 2019 at 8:34 am #4559331

martinaB-12

No, nothing else. I've created english version and than translated it by clicking on "Edit the Italian translation".
But it doesn't work on italian website.
What can I do?

September 16, 2019 at 12:07 pm #4579981

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Martina,

I was able to create a this template on my website and make it work for the translated category too. I tried to do the same changes on your website but the translated template is still not using the right structure.

In this case, could you deactivate all the plugins not related to WPML (and Elementor), activate a default theme (like Twenty Nineteen), and tell me if the category in Italian is still not using the right template. I'm thinking that maybe there's a compatibility issue with one of the plugins you're using since things are working well on my side.

Please let me know how this goes.

Thanks,
Radu

The topic ‘[Closed] Product Archive not displaying in other languages’ is closed to new replies.