This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: In my woocommerce store the product attributes filters appears twice in the sidebar filter.

Solution: The issue was caused by the Remove Category URL plugin

Relevant Documentation:

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 11, 2018 at 11:56 am #2808019

tamasV-3

Hello!

I'd like to ask some help.

In my woocommerce store the product attributes filters appears twice in the sidebar filter.

hidden link

Could you help me please how can I fix it?

Thanks,
Tamas

October 12, 2018 at 4:11 am #2810724

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.
I will do my best to help you solve this issue.

1.- I would like to ask you to follow this steps:
- Go to Woocommerce -> Woocommerce Mutilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync all products.

Please let me know if the issue persists.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Note: The theme of the site doesn't appear in our Multilingual-Ready Themes list, which means that our compatibility team hasn't validated it yet. You can double check in this link: https://wpml.org/documentation/theme-compatibility/

Kind regards,
Carlos

October 12, 2018 at 9:57 am #2811531

tamasV-3

Hello Carlos!

Thank you for your help.

Unfortunately the issue still occur.

Would it make sense to reset all settings and build again everything from scratch?

Thanks,
Tamas

October 12, 2018 at 12:32 pm #2811984

tamasV-3

I've reinstalled the site and started to build the translation again. Everything went fine. I've translated the Woocommerce attributes and until I did not translate the first product, the attributes appear well in the sidebar filter.

After I translated the first product, the attributes doubled in the sidebar.

hidden link

I synced everything I could.

Thanks!

October 12, 2018 at 5:54 pm #2812869

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Tamas,
Thank you very much for your message.

Could you tell me if this filters are from Woocommerce, the theme o a plugin?

Maybe the issue is in the code that display the attributes.
Best regards,
Carlos

October 12, 2018 at 6:22 pm #2812882

tamasV-3

Thank you for your assistant Carlos!

I've found the problem. It caused by the Remove Category URL plugin.

October 12, 2018 at 7:15 pm #2812953

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Tamas,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos