This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by abbasA-3 1 week, 1 day ago.

Assigned support staff: Bigul.

Author Posts
September 28, 2019 at 7:51 am #4658073

abbasA-3

I am trying to:
translate the product attributes
Link to a page where the issue can be seen:
I expected to see:
translated product attributes in english
Instead, I got:
they still showing as arabic

September 29, 2019 at 5:40 pm #4661145

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

Please check the following documentation and make sure you are following the exact steps to translate Product Attributes.

https://wpml.org/documentation/related-projects/woocommerce-multilingual/#taxonomies

Are you trying to translating Custom Product Attributes?

--
Thanks!

Bigul

September 29, 2019 at 7:36 pm #4661293

abbasA-3

Hi,
yes its custom attributes, I have attached an image, you can see that I have already translate it,but I when go to English version of my site I still see the Arabic not the English translation

September 30, 2019 at 12:45 pm #4664651

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please try the following steps and make sure you are getting the expected result.

1) Visit WPML>>Languages
2) Scroll down to *Make themes work multilingual* section
3) Enable *Adjust IDs for multilingual functionality* option
4) Scroll down to *Language filtering for AJAX operations* section
5) Enable *Store a language cookie to support language filtering for AJAX* option

Also please share the URL of the Product having this issue.

--
Thanks!

Bigul

September 30, 2019 at 3:34 pm #4666067

abbasA-3

Hi,
It's already enabled for both of options,
for product, just visit any product then ADDITIONAL INFORMATION after you switch the language to english.
you see the Arabic content which shouldn't .
I want to share with a user, but I cannot see hidden fields

October 1, 2019 at 9:42 am #4670455

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Please try the following steps after a site backup and make sure you are getting the expected result or not.

1) Visit WPML>>String Translation
2) Search for Product Attribute label string
3) Delete the string
4) Refresh the WPML>>String Translation page
5) Retranslate Product Attribute label string from WPML>>String Translation or WooCommerce>>WooCommerce Multilingual>>Attributes screen

--
Thanks!

Bigul

October 1, 2019 at 1:22 pm #4672345

abbasA-3

Hi,
I have tried to delete multiple time and translate it again and again...still showing Arabic text in English.
I can provide to access so you can check,
After I have delete the strings I have return the attributes in Woo-commerce Multilingual,
as you see it's identify the source as Arabic in English version, I have tried switched the strings in String Translation, didn't work !!
T_T

October 1, 2019 at 5:51 pm #4674473

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please switch for a moment to a WordPress default theme like 2017 after site backup and make sure the issue is existing.

--
Thanks!

Bigul

October 1, 2019 at 7:13 pm #4675037

abbasA-3

Already tried it before with different theme, same case.
Am really stuck here

October 2, 2019 at 4:04 pm #4681947

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

October 7, 2019 at 8:21 am #4705251

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the staging site information and updates. The Attribute label strings are showing the translation when I tried with the beta version of WPML 4.3(the upcoming version). Please check the attached images for more details.

The WPML 4.3 version is currently in the QA stage and it has a lot of improvements especially in the string translation, which will fix this issue. But because of the Beta version, it is not recommended in the live site.

Please check and let me know your feedback.

--
Thanks!

Bigul

October 7, 2019 at 10:13 am #4706155

abbasA-3

Hi,
Thanks but I have found another way to fix the issue,
I have change the original Attribute name from Arabic to English then I have translate it to Arabic.
So it works fine now.
Thanks

October 7, 2019 at 10:14 am #4706157

abbasA-3

My issue is resolved now. Thank you!