This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by jenniferL-9 3 weeks, 6 days ago.

Assigned support staff: Bruno.

Author Posts
July 26, 2019 at 4:55 pm #4291083

jenniferL-9

I am trying to: Translate all of my woocommerce products into German, French, Spanish. However after completely translating them, the product attributes such as size, color, etc and variations are not showing on the product page in German and other languages. Please see attached image where it says "Fabre and Grosse" for size and color.

Link to a page where the issue can be seen: hidden link
Specific product: hidden link

I expected to see: Product attributes/variations - color, size, band etc. to appear on the product page.

Instead, I got:None of the product attributes/variations are appearing in secondary langauge (i.e. German). So my customers cannot buy from the translated German site.

July 27, 2019 at 12:40 am #4292065

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, follow the steps below:

- Click on the WPML > Support > Troubleshooting
- Look at the "Clean up" section
- Select the "variations"
- Click on the "Synchronize posts taxonomies" button

Also:

- Click on the WooCommerce > WooCommerce Multilingual > Settings
- Click on the Troubleshooting (at the bottom of the page)
- Select these options:
[ X ] Update products count
[ X ] Sync products variations
[ X ] Sync product stock quantity and status
- Click on the Start button

After following these steps, please let me know if the problem persists.

Thank you.

July 29, 2019 at 5:12 pm #4302393

jenniferL-9

Hi Bruno,

Thank you for your suggestions. However, I followed all the steps but the variations are still not appearing in the translated product pages. Do I need to clear any cache or reset WPML settings? Please let me know if you need admin access to the website.

Thank you!

July 30, 2019 at 7:10 pm #4310287

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

August 8, 2019 at 1:39 am #4358751

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. Sorry for the delay. I have made a copy of your site and I will test your site in my test environment. Soon I will contact you soon.

Thank you.

August 14, 2019 at 10:49 pm #4397893

jenniferL-9

Hi Bruno,

Thanks for the update. Have you resolved the issue on the missing variations in the translated language? Let me know if you need anything.

-Jennifer

August 16, 2019 at 1:47 am #4403917

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Jennifer,

My sincere apologies for the delay. I am still working on your ticket. Soon I will contact you.

I will probably need to forward this to 2nd tier support. I will test more and soon I will contact you.

Thank you.

August 20, 2019 at 12:17 am #4419547

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Just as an update, I've submitted your ticket to 2nd tier support so they can check it out. As soon as I have a 2nd tier support answer I will contact you.

Thank you.

August 20, 2019 at 3:10 pm #4424861

jenniferL-9

Thank you for letting me know. Hope this can be resolved soon. Let me know if they need any other information.

August 24, 2019 at 12:30 am #4450031

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Just as an update, 2nd tier support is already looking at this issue. Soon we will contact you.

Thank you.

September 3, 2019 at 4:35 pm #4506375

jenniferL-9

Hi Bruno,

It's been over a month since this issue has not been resolved. Has any solution been found? Can I speak to a 2nd tier representative who can help resolve this issue? Thanks!

September 4, 2019 at 12:27 am #4507555

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

My sincere apologies for the delay. Usually, 2nd tier support fixes the issue and then tells us step by step so we can update the client.

I updated 2nd tier support again. I will wait for the answer so we can check the next steps.

Again, sorry for the delay.

September 19, 2019 at 2:28 pm #4606337

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello!
I am George from 2nd tier support and I was checking your reported issue.
From what I see, the attribute for the variable product is not translated.
You need to translate that first (also it was set to not be translated in WPML > Settings)
If this does not help, then I suggest that you should perhaps re-send the product to translation from WPML > Translation Management Dashboard or the easy alternative - to remove the translation of that product and create a new translation.

Please let me know how it goes.

September 20, 2019 at 4:44 pm #4613663

jenniferL-9

After updating the plugin, the issue resolved on its own. Thank you!