Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Otto 2 years, 11 months ago.

Assigned support staff: Otto.

Author Posts
October 27, 2017 at 9:10 am

Jurgen

I am trying to: show a product bundle in the 2nd and 3rd language

Link to a page where the issue can be seen: hidden link

I expected to see: as in English hidden link

Instead, I got: "undefined" products

The product bundle can't be bought in translations because of this. I also created a new product bundle (the product bundle from the URL above has been created when Product Bundles V4 was active) and then the drop downs are visible but not restricted nor defaulted (now in draft).
Everything has been translated and latest versions of plugins are used...

October 29, 2017 at 10:40 pm #1415182

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I noted that this bundled product is working fine, right?
hidden link

Please try updating the original bundled products and its translations.

Just go to the original bundled product, update. Then go to the translations, mark as completed and update too.

Let me know if this helps, please.

Kind Regards,

Otto

October 30, 2017 at 6:37 am #1415263

Jurgen

Hi Otto,

Unfortunately it's not working fine: if you have a look at the French version of that bundle, you will see also "undefined" products (while these are translated as it should be, according to me). The English & Dutch versions of this bundle seem ok, but if you add it to your cart in one of those languages and then switch language in the cart, you also get an error message once you are back on the translated cart: "Apero Gift Set (apero cadeau set)" cannot be purchased – some of its contents are missing from your cart.

I already found the possibility on the WPML forum that saving the product and its translation might solve it, so I did that but no success... I even unchecked "mark as completed", saved, returned to the translation and checked "mark as completed" again, but upon saving that, I don't see any changes... I even did this to both the bundles and products themselves but still...

I even tried a new bundle (still in draft, so you need to connect):
- English: hidden link (seems ok)
- Dutch: hidden link (restrictions and defaulting are gone)
- French: hidden link (similar as in Dutch)

Hopefully we can find out why it's not working (if I have to create the bundles again, that's not a disaster but it needs to work as expected)...

Best regards,
Jurgen

October 30, 2017 at 12:09 pm #1415601

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks.

Is it possible for you to do the following test to check for compatibility issues?
-Back up your site first
-Deactivate all the plugins that are not related to WPML, keep also WooCommerce, WooCommerce Product Bundles and WooCommerce Multilingual
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-Create a new bundled product
-If the issue is gone, activate one by one to see with which one there is an interaction issue

Also, please check if you can redefine the bundled products and save them using the standard editor:
- WooCommerce > WooCommerce Multilingual > Settings
- Product Translation Interface
x WPML Translation Editor
o Native WooCommerce product editing screen

Documentation:
https://wpml.org/documentation/related-projects/woocommerce-multilingual/

Save the product this way and check if it solves the issue.

Thanks for your cooperation.

Let me know your results, please.

Kind Regards,

Otto

October 31, 2017 at 10:56 am #1416628

Jurgen

Hi Otto,

I created a staging copy of the website and did the things your requested (only Woo, WPML & WCML plugins activated). I created a new product bundle using the "live" theme and WPML Translation Editor & another one with TwentyFifteen and the native editing product screen. Unfortunately none of these are as it should be.

Can you re-open the private part to mention the staging credentials? Hence you can have a look and play around as much as needed.

Best regards,
Jurgen

October 31, 2017 at 10:41 pm #1417390

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Jurgen,

Thanks. And please apologize for the delay, reply time should be back to normal now.

I enabled a private reply box.

Kind Regards,

Otto

November 1, 2017 at 11:51 am
November 1, 2017 at 2:36 pm #1417960

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you!

I managed to reproduce the problem in a fresh install.

It seems related to variation filtering.

I created two products to bundle, one simple and one variable. And translated them using the "duplicate" option.

Then created the bundled product, and translated it using the duplicate option too.

So far so good.

Then, I filtered a variation in the original product. This change wasn't applied in the translated products.

When I tried to edit the translation using the Translation Editor there is no field for the filtered variations.

If I use the standard editor and edit the product, then the "undefined" problem appears.

Can you confirm following these steps?

It looks like a compatibility issue with the filter variations option. As soon as you confirm I will escalate to our compatibility team.

Thanks for your cooperation.

Kind Regards,

Otto

November 2, 2017 at 10:10 am #1418759

Jurgen

Hi Otto,

Yes indeed that is the same result and those reproduction steps are correct.

Hopefully this can be solved quickly so I can offer product bundles for the upcoming xmas period...

Best regards,
Jurgen

November 2, 2017 at 1:07 pm #1419038

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks. We will do our best 🙂

I forwarded the ticket to our Themes & Plugins Compatibility Team and they will investigate further and contact the author if needed.

Kind Regards,

Otto

November 11, 2017 at 5:12 pm #1427924

Jurgen

Hello,

Do you have any update on (the timing of) the solution for this ticket?

Thanks!

Best regards,
Jurgen

November 13, 2017 at 12:26 pm #1428852

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Jurgen,

The issue should be fixed in the next WCML release.

I can't provide an ETA for it, but it should be around soon (a couple of weeks, maybe a month).

Hopefully, it will be available before Christmas 🙂

Kind Regards,

Otto

November 26, 2017 at 1:26 pm #1441620

Jurgen

Hello,

I updated my system:
- WordPress 4.9
- WooCommerce 3.2.5
- WooCommerce Product Bundles 5.6.1
- WPML 3.8.4 (and other WPML plugins as well up to date)
- WooCommerce MultiLingual 4.2.6

I tested an existing product bundle but if you define 1 "filter variation" + 1 "override default selection", the translated bundles are still not correct:
- in the base language you see no drop down, just the chosen value as a word (which is as it should be).
- in the translations you see the translated label but there is no value, neither a drop down to choose from (there do is the message that you need to make a choice to be able to proceed, which is not possible).

I tested as well by creating a new product bundle (as well with 1 filter + 1 default selection) and the issue is there too.

It do seems to be ok if you don't limit the possible options (no idea if defaulting goes right in the translations).

Best regards,
Jurgen

November 29, 2017 at 4:03 pm #1445006

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Jurgen,

Please apologize for the delay.

I couldn't reproduce the issue, is it OK if I log in to your site again? Maybe I'll need to copy it again.

If you need to send new ones, please edit the previous private reply. Then let me know in a public post. Otherwise, I won't be notified.

Don't publish access data in a normal post, they will be exposed.

Thank you!

Kind Regards,

Otto

November 30, 2017 at 10:51 am #1445655

Jurgen

Hi Otto,

Thanks for checking!

I updated the above mentioned staging website, so all active plugins are up to date. The only difference in the mean time is the WP 4.9.1 .

You can access the staging URL as mentioned above (nothing changed) & you can look for the "PEILI Bowl|Dish with Liner Gift Set" product bundle to see the issue in the 2nd and 3rd language.

Best regards,
Jurgen