Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 44 replies, has 2 voices.

Last updated by Carlos Rojas 4 years ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 13, 2017 at 10:32 pm #1319246

Alex Asimakopoulos

I am trying to: see the woocommerce product categories

Link to my site:hidden link

I expected to see:

Instead, I got:When i am on woocommerce multilangual i can't see the product categories, it is seen that is loading but it doesn't load something eventually. ( i got on Custom taxonomies but i can't click on translate, it is clicked the do nothing). Same happens and on tags

cat.png
July 13, 2017 at 11:30 pm #1319253

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello Alex,
Thank you for contacting WPML support. I'll be happy to help you with this.

It seems that the theme you are using is not compatible with WPML. You can check it in this link: https://wpml.org/documentation/theme-compatibility/

Please let me know if you need any further assistance and I will be happy to help.
Kind regards,
Carlos

July 17, 2017 at 8:08 am #1320531

Alex Asimakopoulos

Thank you Carlos for your reply!!:-) Ok but isn't is strange that the attributes doesn't have problem?

July 17, 2017 at 2:56 pm #1320995

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

Yes, this is unusual. Could you check in the Console to see if there is any JS conflict?

Also increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Please let me know if you see any results?

Regards,
Carlos

July 17, 2017 at 10:56 pm #1321404

Alex Asimakopoulos

Hello Carlos and thank you for your reply!! yes you have right!! i send you printscreen. what should i do?

wpml_tags.png
wpml_cat.png
July 17, 2017 at 11:02 pm #1321408

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

Please follow this steps in order to isolate the cause of the issue:
- Deactivate all plugins except Woocommerce and WPML plugins.
- Activate a default WordPress theme like Twenty Sixteen.
- Clear all possible cache (server-side and browser-side).
- Check if the problem disappeared.
- In case the issue disappear activate the plugins one by one, and then the theme until you see which one is causing the conflict.

Please let me know the results.
Kind regards,
Carlos

July 21, 2017 at 7:08 am #1324219

Alex Asimakopoulos

Hello Carlos, and thnak you for your reply. I changed as you said theme and it works fine. I contacted with the theme and they send me this
Many thank you for your email.

about the issues, I saw that the result is from the plugin.
They have error on javascript, not from our theme or plugins.

Please contact them to get more details.

Hope that convenient for your plan.

July 21, 2017 at 7:34 am #1324227

Alex Asimakopoulos

I said that i change theme and it is theme error and they reply to that
Thank you for your reply.

I mean the category issues, do they have any instruction to solve that?

I saw the return values from that plugin, it does not load some part.

Looking forward to your reply.

July 21, 2017 at 2:48 pm #1324600

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

I'm not quite sure about your answer. Did you test with a minimal WordPress installation and the plugin worked fine?

Looking forward to your answer.

Regards,
Carlos

July 24, 2017 at 9:41 pm #1326180

Alex Asimakopoulos

Hello Carlos and thank you for your reply. I didn't have to disable the plugins. I only change theme to wordpress default (Twenty Sixteen) and it worked fine. So i contact with the theme but they said to me that "about the issues, I saw that the result is from the plugin (wpml).
They have error on javascript, not from our theme or plugins.

Please contact them to get more details.

Hope that convenient for your plan."

And then I said to them that i change theme and it is theme error and they reply to that: "Thank you for your reply.

I mean the category issues, do they have any instruction to solve that?

I saw the return values from that plugin, it does not load some part.

Looking forward to your reply."

July 25, 2017 at 1:54 pm #1326689

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

Please add this code to your functions.php file:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );

--

Let me know what error do you see on the error log. You can more information related to WordPress debugging in this link: https://codex.wordpress.org/Debugging_in_WordPress

Regards,
Carlos

July 26, 2017 at 9:16 am #1327302

Alex Asimakopoulos

Hello Carlos and thank you for your reply. I have added it on functions.php but it didn't show something. Then i also added on wp-config.php but nothing changed. What else shoul i do?

July 26, 2017 at 2:17 pm #1327667

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

In your WordPress installation you will find the error log file (https://cdn.wpml.org/wp-content/debug.log). Could tell me what are the latest errors in this file?

Regards,
Carlos

July 26, 2017 at 10:54 pm #1328054

Alex Asimakopoulos

Hello Carlos and thank you for your reply. I have an old log from 6-7-17. I delete it to see if anything changes but nothing. So i upload it again but still nothing. Also i added the lines on the theme functions.php but no change. Am i doing something wrong?

July 27, 2017 at 2:12 pm #1328895

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos