Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 44 replies, has 2 voices.

Last updated by Carlos Rojas 3 years ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 13, 2017 at 8:34 pm #1341034

Alex Asimakopoulos

Hello Carlos and thank you for your reply, i will search it why it does that. But ok it's fine with me your solution. I took a backup from the site so there would not be a problem. Let me know if you want to do something.

August 14, 2017 at 1:45 pm #1341731

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

I sent you an email to the address you added in your user account. Please let me know if you got the email and answer me through here.

Kind regards,
Carlos

August 16, 2017 at 2:34 pm #1344575

Alex Asimakopoulos

Hello Carlos,

Unfortunately problem still remains...
When I navigate to a product page (lets say hidden link) the language switcher on the top right of the page does not work.

Can you please have a look at it?
Thank you in advance!

August 16, 2017 at 6:58 pm #1344759

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

The language switcher is working fine, the issue is caused by the HTML + CSS of the theme. The div with the id 'container' and the div with the id 'openCloseWrap' are overlapped above the language switcher. Please modify the CSS to make the language switcher don't be 'under' this layers and the issue will be solved.

Kind regards,
Carlos

August 28, 2017 at 8:53 pm #1352761

Alex Asimakopoulos

Thank you Carlos yes i fixed the cssm can you please tell me what was the problem on the categories and didn't show up? and what should i change on the site that i build? thank you in advance

August 28, 2017 at 9:05 pm #1352767

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

Regarding the taxonomies, the issue was in the wpml-config.xml file, this helps WPML to translate your site and it's saved in the root folder of the theme. You can read more about this file in this link: https://wpml.org/documentation/support/language-configuration-files/

Kind regards,
Carlos

August 29, 2017 at 7:09 am #1352983

Alex Asimakopoulos

Thank you for your response Carlos! Where can i see the changes you have made on wpml-config.xml (or on more files ) so i can change and the live site to work like the host that you fix it?

August 29, 2017 at 11:37 am #1353277

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,
Please find the changes made to the wpml-config.xml file in a message I sent you earlier in this ticket.
Regards,
Carlos

August 29, 2017 at 9:10 pm #1353812

Alex Asimakopoulos

Hello Carlos and thank you for your reply i am confused and i didn't could do it successfully. Can we please migrate the solution like we said in the start please?
Because my boss is in a hurry. Can you please tell me how to migrate the solution?
Thank you in advance

August 29, 2017 at 9:34 pm #1353816

Alex Asimakopoulos

I took a backup so there would be no problem

August 30, 2017 at 12:51 pm #1354293

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

I share a folder with the theme fixed. You should get an email with the download link.
Please make a backup of your site and test this theme.

Let me know if this solved the issue.

Kind regards,
Carlos

September 4, 2017 at 7:26 am #1356923

Alex Asimakopoulos

Thank you Carlos! You are the best!!! i exported the site from the host and import it. The only problem that i see is when i go on all products. There the language switcher isn't working. Can you please help me with that last to go live? You can see it hidden link

September 4, 2017 at 12:16 pm #1357746

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

The cause of the issue was that the translation wasn't finished, I just finished and now the page is working in both languages. Please remember to update the outdated plugins and themes, specially Woocommerce.

Kind regards,
Carlos

September 4, 2017 at 1:04 pm #1357825

Alex Asimakopoulos

Thamk you Carlos!!! You are the best!!!

September 4, 2017 at 2:24 pm #1358006

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

I'm glad this issue is solved 🙂

We are always here to help, so please don't hesitate to open another ticket if you have any other issues with WPML.
Kind regards,
Carlos