Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 4, 2015 at 2:41 pm #611390

muhammad-mustafaN

Hi , I have a problem with product categories on my menu , in English language ( default ) everything is okay , but when I switch language to Persian some of product categories not working in internet explorer and Firefox it show internal error but it`s working with google chrome .
Ex :
English version : hidden link

Persian Version : hidden link

But is some categories it`s works fine
Ex :

English : hidden link

Persian : hidden link

What should I do about please tell me !
Thank you

May 4, 2015 at 4:33 pm #611476

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Thanks for contacting WPML support forum.

I've checked in Chrome and the category page that you've noticed that does not work, it does not work in Chrome or Firefox, so, I don't think is a browser related issue. So, for being of better help, could you please enable WP debug mode:
http://codex.wordpress.org/WP_DEBUG

To enable it, open your wp-config.php file and look for

define('WP_DEBUG', false);

Change it to:

define('WP_DEBUG', true);

In order to enable the error logging to a file on the server you need to add yet one more similar line:

define( 'WP_DEBUG_LOG', true );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

define( 'WP_DEBUG_DISPLAY', true );>/code>

The wp-config.php is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

[php]/* That's all, stop editing! Happy blogging. */

Please note that you’ll see everything, not only related to WPML.

This will most likely include messages from other plugins, your theme and sometimes even WordPress core. The messages appear all over the place.

Sometimes they appear right on top, but they can also appear in the middle of the page.

You can read more here:
https://wpml.org/documentation/support/debugging-wpml/

I'll wait for your reply,
Andrés

May 4, 2015 at 5:38 pm #611531

muhammad-mustafaN

Hi Andres , thanks for your replay
As you said I enabled debugging mode for WordPress , Then I tried again , I disabled WPML Sticky plugin and again I tried those categories in Internet Explorer , and it seems worked , then I enable it again and find some problem , I tired and I got this :

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32768 bytes) in /home/grandilc/domains/grandilco.com/public_html/wp-content/plugins/wordfence/lib/wfBrowscapCache.php on line 62661
It bcz I have a plugin called wordfence ,I disabled the plugin and it worked again in explorer , when Sticky is enable and wordfence plugin is enable I have problem , but whne one of them is disabled , it`s working , I not sure about it .
Here is log file please look at it and let me know .

hidden link

Again thank you sorry for your time much appreciate it .
Thanks

May 5, 2015 at 7:52 am #611860

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello,

I would like to check a couple of settings in your site, but as you say, it looks like the problem is related to a compatibility problem with other plugin.
I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Andrés

May 5, 2015 at 11:03 am #612092

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Thank you for your information Muhammad.
Unfortunately, I'm not able to get in into your site, Wordfence does not allow it. Could you deactivate it please?

Thank you,
Andrés

May 5, 2015 at 11:57 am #612159

muhammad-mustafaN

Hi Andres, sorry about that I just disable it u can try it now ! , and please check issue when this plugin is enable too !

May 5, 2015 at 4:27 pm #612453

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Thank you, Muhammad.
I think the problem is solved, even with Wordfence activated. Can you please make a general check of your site?

I'll wait for your confirmation
Andrés

May 5, 2015 at 6:21 pm #612557

muhammad-mustafaN

Hi , Andres many thanks for your replay , but after I enable wpml sticky Link plugin I`m getting same issue with internet explorer and Firefox http 500 internal server error
Link : hidden link
You check it , may there is problem with sticky link , what do you think problem is ?!
Thank you much appreciate it !

May 6, 2015 at 11:08 am #613071

Mladen Andrejic

Hello,

Andrés is not here today and I will take care of his tickets, I hope this is okay?

There is one more thing I would like to note about the original issue :

1. Please go to WPML > String Translation
2. In search bar type product-category
3. When you find it, translate it to Farsi and mark as "Translation Complete" and save it

For the other issue you reported, I am sorry, but I can not see it (Please see the screenshot : hidden link )

But if you are still experiencing Internal Server Error 500 issues and this is not original issue (of this ticket), may I kindly ask you to start new thread for it? With policy one ticket = one problem, we can provide better support and our clients with the same problem can easily find the fix for it. I hope this makes sense?

In the thread you start, you could provide some screenshots of how you see and where you get the issue, for better understanding.

Thanks.

May 6, 2015 at 11:35 am #613098

muhammad-mustafaN

Hi Mladen Thank you for your replay , WPML string translation for product-category is completed , about the new thread as you said , http 500 internal server error is related to this thread , when I

m going to product category in Persian language with Firefox or Internet explorer I

m getting this error ,

Here is Persian Language :

hidden link

Same Product Category for English language :

hidden link

When I open it with Internet Explorer I

m getting Internal Error , when I

m disable WPML Sticky link it`ll open it ! With Google Chorom everything is okay !
I attach the Screenshot too , Thank you much appreciate it ! I'm waiting for your replay .

May 6, 2015 at 11:49 am #613113

Mladen Andrejic

Hello,

Thank you for the informations, since it's working with Google Chrome (I checked it in Safari and everything seems fine), can you please check in Incognito Window for Internet Explorer, as this may be cache issue you are experiencing.

If in incognito everything works fine, just clear the cache or delete cookies.

Also, please try to be sure that this is caused by Sticky Links.

- Disable all non WPML Plugins
- Set the theme to default Twenty Fourteen

and check if the issue now appears?

If the issue still appears, this can be caused by server as well, and you should check this link here hidden link

Thanks.

The topic ‘[Closed] Product Category not showing n internet explorer and fire foz’ is closed to new replies.