This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WPML 3.9 had brought an issue with Custom Post Types (or Products) returning a page not found -> error (404).

Solution: This issue is fixed already with WPML 3.9.1 so if you have this issue please update to WPML 3.9.1 (you should see an update message in your plugins page)

Then please go to Settings -> Permalinks and click Save Changes without making any changes.

Relevant Documentation: https://wpml.org/faq/install-wpml/

This topic contains 12 replies, has 4 voices.

Last updated by davideG-16 1 year, 9 months ago.

Assigned support staff: Andrey.

Author Posts
January 16, 2018 at 7:42 am #1485542

Amit
Supporter

Hi all,

WPML 3.9 had brought an issue with Custom Post Types (or Products) returning a page not found -> error (404).

This issue is fixed already with WPML 3.9.1 so if you have this issue please update to WPML 3.9.1 (you should see an update message in your plugins page)

Then please go to Settings -> Permalinks and click Save Changes without making any changes.

If this did not work please leave me a comment here

January 17, 2018 at 12:38 pm #1487300

davideG-16

Hi, my version is WPML 3.9.1 and I save permalinks without any changes but I have the same problem! How can I solve it?

January 17, 2018 at 6:05 pm #1487720

davideG-16

I still need support! Doesn’t work... I know you have top Much request but the English version is unusable.

January 18, 2018 at 8:26 am #1488136

Amit
Supporter

Hi,

I am not sure why this is still happening in your case, I have enabled the private box for you to be able to add your login details,

Please add the credentials there so I can have a look.

January 18, 2018 at 10:17 am #1488340

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

This is Andrey here from the WPML support team.

@davideg-16, I have checked the problem and fixed it. It was an issue with the shop slug. In the Settings >> Permalinks, I changed /shop/%product_cat%/ to /negozio/%product_cat%/, chose Italian for that string and translated it in the WPML >> String Translation (or Woocommerce >> Woocomerce Multilingual > URLs). After, just refreshed the permalinks. The reason I did this as your shop page originally was created in the Italian language.

January 18, 2018 at 10:46 am #1488373

davideG-16

MANY MANY THANKS!

January 19, 2018 at 6:31 pm #1490282

davideG-16

Hi, for products is ok... but I have the same problem with categories: hidden link, how can I solve it?

January 19, 2018 at 9:36 pm #1490414

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

As far as I can see your category URL is hidden link, and it does work. Could you please check it out?

January 20, 2018 at 8:31 am #1490573

davideG-16

It seems the P of Product is not UPPERCASE, and with p it works... But in the google indexing was P and not p and now I have the 404 error from google search....
I will replace all link and I upload again the sitemap...

January 20, 2018 at 8:39 am #1490576

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Thanks for your feedback. In my opinion, it is better to keep lowercase letters in the URLs. But if you still need to have it back, please add the custom product-category in the Settings >> Permalinks.
I am closing this ticket as the original issue has been resolved with a new release. Feel free to open a new ticket, if you need further help.

January 29, 2018 at 9:37 am #1499773

geraldineB-3

Hi,

My product category URL returns also error (404). I have WPML multilingual CMS version 3.9.2, and have updated the settings>permalinks, but it didn't solve the problem. Maybe I am in the same situation as davideG-16, as my site was in French first. I noticed that my URL hidden link is automatically changed into hidden link on the site.
But I don't understand how to solve it.

February 6, 2018 at 2:38 pm #1508704

davideG-16

Hi, I would like to open again this ticket because after that I have a lot of problems with english version, I have "only for the English version" 178 errors (404). So I need you help ...
I did the redirection but google always says it's wrong (404).

It seems the P of Product is not UPPERCASE, and with p it works... But in the google indexing was P and not p and now I have the 404 error from google search....
I will replace all link and I upload again the sitemap...

My question is:
could I have product_category in italian and Product_Category in english?
How can I change the category and the tag only in English? do i have to go in string translator? are they already translated and how do they change?

I hope to solve this. Best Regards.

February 6, 2018 at 6:48 pm #1509033

davideG-16

One more thing:
the home page is now indexed in English, the link is /it but the description is in English, use yoast seo plugin.... do you know how to solve?