This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Mihai Apetrei 6 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
March 4, 2019 at 1:55 pm #3269125

laurenceC-6

I am trying to: translate description tab in products pages

Link to a page where the issue can be seen:hidden link

I expected to see:language variations for product description

Instead, I got:tab missing

March 5, 2019 at 3:18 pm #3274794

laurenceC-6

Hello the product description for product pages is not showing for language versions can you let me know how to fix this?

March 5, 2019 at 6:21 pm #3275692

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I was not able to find out what is the other language of the site and find an example page where the product description is missing. Can you please help me with that information?

Also, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

March 6, 2019 at 4:39 pm #3280459

laurenceC-6

Hello why is there a description on this page

hidden link

and not on this page

hidden link

March 6, 2019 at 4:40 pm #3280463

laurenceC-6

I meant

hidden link

and

hidden link

March 6, 2019 at 6:49 pm #3281008

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the links.

I can now see the issue happening.

From what I can see, that div is empty in the translation (I am attaching a screenshot). I would need to have access to the site to look into this a little bit deeper.

Can you please share your site's access to that I can analyze things a bit? Also, are you sure that you added a description for the translation of the product?

PS: Can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai

March 8, 2019 at 1:45 pm #3292766

laurenceC-6

Warning: Invalid argument supplied for foreach() in /var/www/vhosts/staging2.s1.icklebubba.com/httpdocs/wp-content/plugins/woocommerce-multilingual/inc/translation-editor/class-wcml-page-builders.php on line 74

March 11, 2019 at 12:21 pm #3310873

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you very much for your patience and I am very sorry for the delay in response but our ticket queue has been really full and I also don't work on the weekends.

From my understanding by looking at your last reply, there is also a different issue happening.

In our forum, we try to keep one issue per ticket.


Continuing with one issue per ticket helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster so may I kindly ask you to please open a new ticket for the additional issue?

Thank you for your understanding.

Now, back to the current issue that you mentioned when you opened this ticket: I did not receive from you until now any credentials for the site and as long as I don't have any access to your site, all I can do is just guess and guessing can't be as accurate as seeing the site and be able to test a few things.

So, can you please let me know if you are ok with sharing the credentials for the site?

There are some private fields that I am activating under my reply and I would need you to complete them so that I get access to your site.

1. If you don't see those fields, please try visiting this page into a new incognito browser window or into a completely different browser (first don't forget to log into your WPML.org account before you visit the ticket page) as the issue might be caused by caching or by a certain browser extension that you use.

2. If you don't want me to access your live site, I can send you some quick steps that you can follow to migrate your site on a testing server of ours. Please let me know if you prefer that and I will get back to you with the proper steps.

I will be waiting for your response.

Kind regards,
Mihai

March 13, 2019 at 10:29 am #3331929

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

Now, that I have access to a site where I can actually see and test things, everything should be happening faster.

As a first step, can you please:

1. create a full backup of the current staging site
2. go here (hidden link), register WPML by generating a key from your WPML.org account and then update the WPML add-ons

Here you can find the process that you can follow for registering WPML on a site:
https://wpml.org/faq/install-wpml/#register

Please let me know when that's done.

Kind regards,
Mihai

March 14, 2019 at 1:43 pm #3345093

laurenceC-6

update with staging2 key for wpml

error message when update

Update Failed:
504 Gateway Time-out

504 Gateway Time-out
nginx

<!-- a padding to disable MSIE and Chrome friendly error page -->
<!-- a padding to disable MSIE and Chrome friendly error page -->
<!-- a padding to disable MSIE and Chrome friendly error page -->
<!-- a padding to disable MSIE and Chrome friendly error page -->
<!-- a padding to disable MSIE and Chrome friendly error page -->
<!-- a padding to disable MSIE and Chrome friendly error page -->

March 14, 2019 at 5:24 pm #3347427

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

As far as I see, I am not able to access the staging environment anymore with the credentials you shared with me before so I can't take a look but that sounds like a really weird issue.

It feels to me that somehow the server is failing in connecting with the WPML service.

1. Can you please try to register the key once more?

2. If that doesn't work, we can go with the manual process of updating the plugins.

❌ Before proceeding please make a full website backup! ❌

  • download the latest version of the WPML add-ons from https://wpml.org/account/downloads/;
  • disable each of the add-ons
  • delete the add-ons from your WordPress panel (the settings and the translations are saved in the database so they will not be deleted);
  • upload the freshly downloaded WPML add-ons plugins from Plugins → Add New → Upload Plugin
    → Activate WPML
    ;

Please let me know how that process goes.

I will be waiting for your reply.

Kind regards,
Mihai

March 19, 2019 at 9:38 am #3377377

laurenceC-6

Updated plugins

Apologies we synced from live to test for updating plugins so your access was removed by sync I have set it back up please try again

March 20, 2019 at 3:29 pm #3389897

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hello and thank you for the confirmation.

I am happy to see that you were able to update the plugins.

This seems to be a compatibility issue. You are also using many many plugins and one of them might cause that.

1. Can you please try this first:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

2. If the issue is still happening, please try this:

❌ Before proceeding please make a full website backup! ❌

Go to WPML -> Support -> Troubleshooting

Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix terms count"
• "Fix post type assignment for translations"

3. If the issue persists, I will need you to replicate this on a sandbox testing server that I will set up for you and if the issue will happen there, too, I will be able to send it to our compatibility team for further tests.

Also, I will need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents through a link - using a service like pastebin.com.

Please let me know what you are able to find following the steps above.

Kind regards,
Mihai

March 28, 2019 at 10:07 am #3479071

laurenceC-6

Did this but still the same

Go to WPML -> Support -> Troubleshooting

Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix terms count"
• "Fix post type assignment for translations"

March 28, 2019 at 10:10 am #3479117

laurenceC-6

https://pastebin.com/stVRWv9J

The topic ‘[Closed] product description tab missing’ is closed to new replies.