This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Laura 1 month, 1 week ago.

Assigned support staff: Laura.

Author Posts
September 5, 2019 at 9:07 am #4517343

amiraK

We did update woo-commerce and wpml also we did update wordpress version but featured image still not appear in arabic language.

hidden link - working

hidden link not working

September 8, 2019 at 9:11 am #4530965

amiraK

Yes the error still exist, please I need help for solving this problem.

Thanks.

September 9, 2019 at 7:30 am #4534057

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

how is created the gallery on the page? By the theme or are you using some plugin? If this is the case, we need to test for compatibility.

September 9, 2019 at 8:23 am #4534563

amiraK

Hi,
I'm using Woo-commerce products, In previous page I'm using product category added by visual composer which link me to the product page which have the error in Arabic version.

hidden link

September 9, 2019 at 8:58 am #4534887

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

can you provide me with credentials so I can better check the issue? I'll enable a private reply.

September 9, 2019 at 2:04 pm #4537823

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I checked the site but I don't have clear ideas about this. I can see the problem comes from the magnifying box over the product gallery, but I don't know from where this comes from?

It's from the theme? If so, it would be possible to install only the theme in a fresh installation and to reproduce the issue? (I'd give you the link)

Otherwise, I'd take a copy of the site to better check the problem.

September 10, 2019 at 8:37 am #4543079

amiraK

Hi,

Kindly you can take a copy to check the website.

September 10, 2019 at 11:33 am #4544727

amiraK

Hi,

Kindly find the migrated copy of the website on the below URL as you sent it.

hidden link

Thanks.

September 10, 2019 at 1:51 pm #4546147

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

as I was suspecting the issue is with WPBakery. What I don't understand is which module is using the images.

Does the template for product page come with the theme or did you create it? Would you be able to reproduce it in a fresh installation?

September 10, 2019 at 2:05 pm #4546237

amiraK

Hi,

The image is inserted from the product module, so this page is displaying single product from Woo-commerce products.

September 10, 2019 at 2:34 pm #4546507

amiraK

Hi,

Kindly check the below link it looks like a common issue.

https://wpml.org/forums/topic/images-not-showing-in-the-translated-woocommerce-product-page/

September 10, 2019 at 3:52 pm #4547051

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

you are not using a child theme, so the issue can't be the same.

Moreover, I checked with the theme Twenty Nineteen which is compatible with WPML and the issue is the same: hidden link

The problem is with WPBakery. I'll try to replicate the issue on a fresh installation.

September 11, 2019 at 8:37 am #4551731

amiraK

Hi,

You got it, Right when I deactivate WPBakery the image appear.

September 12, 2019 at 8:29 am #4559267

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I did some other tests and I can tell you the issue is not with WPML but with WP Bakery only - this particular image option is not available in RTL mode.

I added a new language to your copy of the site (Italian) and the image appeared just fine.

So I set Arabic as default language and deactivate WPML - now even English products are displayed RTL (because WordPress think they are in Arabic) and as you can see the image is not visible: hidden link

Therefore since this is not WPML related, you should contact WPBakery support and ask them how to display that kind of image in RTL languages.