This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Whenever I switch the page to any other in the shop after adding to cart, I get the following error:

"[name of the product] has been removed from your cart because it has since been modified. You can add it back to your cart here."

Solution: I would like to ask you to follow this steps in order to isolate the cause of the issue: - Back up your site first before making any change, this is for security reasons. - Update all outdated plugins to their latest version. Outdated functionalities can cause conflicts in the code. - Flush any cache memory that might exists. - Go to WPML -> Languages -> Language filtering for AJAX operations -> Activate this option -> Save the changes. - Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync all products.

Relevant Documentation:

This topic contains 3 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 8, 2018 at 10:04 pm

ivanT-3

Add products with variants to cart using a translated version of my site.

Product with selected variant added to cart.

Whenever I switch the page to any other in the shop after adding to cart, I get the following error:

"[name of the product] has been removed from your cart because it has since been modified. You can add it back to your cart here."

October 10, 2018 at 1:40 am #2802440

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support. I will do my best to help you with this.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins to their latest version. Outdated functionalities can cause conflicts in the code.
- Flush any cache memory that might exists.
- Go to WPML -> Languages -> Language filtering for AJAX operations -> Activate this option -> Save the changes.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync all products.

Could you tell me if the issue persists after the steps above?

Kind regards,
Carlos

October 10, 2018 at 6:37 am #2803113

ivanT-3

My issue is resolved now. Thank you!

October 10, 2018 at 3:07 pm #2804922

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos