Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by patrickV-24 1 year, 7 months ago.

Assigned support staff: Bobby.

Author Posts
January 31, 2019 at 11:02 am #3147441

patrickV-24

Tell us what you are trying to do?
I'm trying to add a new language to our website (german) and translate our products. The problem is that I have 1 product that has 2 original languages (see image). This probably is because I used 2 different ways to translate? (via WPML and via WordPress) Is there a way to fix this?

Is there any documentation that you are following?
Documentation on the WPML website: https://wpml.org/documentation/related-projects/woocommerce-multilingual/

Is there a similar example that we can see?
Only if I give you temp admin inlog.

What is the link to your site? hidden link

January 31, 2019 at 7:11 pm #3149520

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

as a test please go to WooCommerce-> WooCommerce Multilingual-> Settings tab-> switch to " native WooCommerce product editing screen"

then you should be able to go in the post edit screen and change the language in the "Language" block on the top right (see attached screenshot).

let me know your results please

February 1, 2019 at 10:31 am #3151221

patrickV-24

Hello Bobby,

I've tryed to change the language of the product but this wasn't possible. I couldn't select anything, this was blocked.

When I change anything on the products, the product doesn't show the atributes/variations on the website.

Have you got any other suggestions?

Best regards,

Patrick

February 1, 2019 at 7:39 pm #3153091

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If possible i would like to take a closer look

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Note : if you are not comfortable with providing access to the backend we can set up a staging environment to further test this

February 4, 2019 at 7:10 pm #3159236

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Patrick,

thank you for setting up the staging environment, unfortunately i cannot access the wp-admin area as it results in 404

if my IP needs to be whitelisted you can try the following IP

45.48.70.119

February 5, 2019 at 7:52 am #3160645

patrickV-24

Hello Bobby,

My mistake, I forgot to remove the blocking of countries outside Europe. I've unblocked the site so now you should be able to access the site.

Best regards, Patrick

February 6, 2019 at 3:16 am #3164185

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

unfortunately I am still receiving the same issue , i have tried using a VPN which worked but not using the VPN would be ideal

at the moment i am getting a 503 error which is not allowing me to continue working on the site

and i do not have access to manually test deactivating WPML to see if that would resolve the 503 error.

additionally it seems that this issue is stemming from the product being created in German first and then being set as the default product with English being set as default as well

it can most likely be resolved by changing the database entry but if it is a simple product i highly recommend just deleting the German version of it, and then going into English and re adding the German translation so the relationship is set correct

February 13, 2019 at 9:45 am #3192927

patrickV-24

My issue is resolved now. Thank you!