Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Osama Mersal 9 months, 3 weeks ago.

Assigned support staff: Osama Mersal.

Author Posts
October 22, 2021 at 9:23 am #9842229

jimeH

Tell us what you are trying to do?
I'm translating products to other languages, but product images aren't duplicated to the new products in second and third language.
Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

October 24, 2021 at 10:22 am #9850983

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I'll be glad to help you today.

1) I've checked this product (hidden link), and found the image is duplicated to all languages.

Would you please tell me how to check or reproduce the issue?

Also, please try the following steps on the products with the issue.
1- Edit the default language product
2- Select the Media Attachment options (Kindly check the attached screenshot)
3- Update the product
4- Update the translation

2) It's not related to the issue, but according to your Debug.info, the WP memory limit needs to be increased. PHP memory is fine, but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb. (Kindly check this page https://wpml.org/home/minimum-requirements/)

Add this to the top of wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Thanks for your cooperation

Regards,
Osama

1.jpg
October 25, 2021 at 8:38 am #9854829

jimeH

The weird thing is that images appear on frontend but in backend i do not see any attached images. Any idea what that might cause?

October 25, 2021 at 9:02 am #9854989

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for the update. Could you please check the following steps?

1- Go to WPML-> Settings-> Media Translation
2- Click on the start button

After that, please try the steps in my previous reply.

I hope this helps you. If you need further info, please let me know.

Best regards,
Osama

The topic ‘[Closed] Product image doesn't appear in other languages’ is closed to new replies.