This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by poliL 4 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 21, 2019 at 8:45 pm #3858757

poliL

I am trying to: after translation, I want to check how the product looks like in Dutch, but the pictures are not showing.

Link to a page where the issue can be seen: hidden link
hidden link

I expected to see: the product pictures accompanying the text.

Instead, I got: no pictures with the product

May 21, 2019 at 10:11 pm #3858953

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Could you please open a product editor page and verify if you enabled the checkboxes for "duplicating" the media attachments? See screenshot attached. If not, please enable to poxes and click update. Then translate the product again. This option is not global and needs to be assigned to each products individually.

If this did not solve the issue please make a backup of your site and database before proceeding.
hidden link

Could you please go to WooCommerce -> WooCommerce Multilingual -> Status and select the troubleshoot option in the right bottom corner of the box?

Now, syncronize all the available possibilities. Let me know if this solved the issue.

Does the issue only occur for some products or all of them? Do you have similar issues with posts or pages?

Kind regards
Andreas

May 22, 2019 at 7:58 am #3862725

poliL

Hi Andreas,

I checked the duplicating boxes; those are ticked. see attachment.

I synced the WooCommerce-Multilingual-troubleshooting boxes; no improvement

The issues occur for all the products.

Yes, I have the same issue for all the pages and posts.

I appreciate your help.

Thanks in advance,

Poli

May 22, 2019 at 10:17 pm #3869633

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 23, 2019 at 9:07 pm #3879389

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The issue was solved after changing the configuration for system custom fields inside of the multilingual content setup of the product editor.

See screenshot attached.

Kind regards
Andreas

May 24, 2019 at 9:34 am #3882967

poliL

Hello Andrea,

Thanks for your help. Your solution seems to work for most of the products, but not for all. Could you please have a look at the product:
hidden link
This one does not improve even after changing the system settings.

By the way, in some products the settings of the header and gallery were set to Copy; I only pressed the apply button and it worked. By the specific product, this does not seem to work. Any idea?

Thanks in advance,
Poli

May 24, 2019 at 3:30 pm #3886055

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

As far I can see the image on the product is displayed and translated but the image dimension is way bigger than the dimension of other images on your site. (See screenshot)

I would adivse you to crop all images to the same size in order to apply the same layout on all pages.

Example: hidden link

Kind regards
Andreas

May 27, 2019 at 11:28 am #3896491

poliL

My issue is resolved now. Thank you!