Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Bigul 8 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
September 14, 2019 at 2:07 am

nikolajW

I am trying to:
I translated the product, without duplicating the images.
The media duplicate option is unchecked.
The translated product should use the same images.
This procedure work for pages and posts, but not for products.

Link to a page where the issue can be seen:
hidden link

I expected to see:
The same images from the main language in the translated version of product page.

Instead, I got:
In product page the images are not visible and not showing up in the media library.

September 16, 2019 at 8:59 am #4577709

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Most probably it will be happening because of the SVG image format. Please check it is happening for the PNG or JPEG images.

Normally WordPress will restrict SVG images because of security reasons. Please check the attached screenshots for more details.

--
Thanks!

Bigul

September 16, 2019 at 11:01 am #4579597

nikolajW

Hey, I know about the SVG, but some of the jpg or png isn't showing up.
See Screenshot.
Every picture is translated in the WMPL Media translation.

Please take a look into the page.

Regards

September 16, 2019 at 4:57 pm #4582773

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It requires further checking. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 17, 2019 at 12:03 am #4584551

nikolajW

Sure! Do it. 🙂

September 17, 2019 at 12:23 pm #4588429

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy of the site and debugging the issue now. Will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

September 18, 2019 at 4:10 pm #4598741

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am continuing the debugging on this issue. As a part of our escalation process, I have tried to reproduce the issue in a fresh installation. But not able to reproduce it exactly. Please check the attached images for more details.

Therefore I have a request. Please visit the following URL and make sure the issue is reproducible or not. It will help us a lot and we can forward it easily to our developers for further debugging.

hidden link

--
Thanks!

Bigul

September 19, 2019 at 12:14 am #4600331

nikolajW

Hmm, I can see on your sandbox, that the product image isn't showing up in the translated product.

On my installation it is visible that some images are translated and others are not.
It seem to be randomly or connected with the product translation.

The translated image in media library on your sandbox also looks different.
Why is that?

Regards

September 19, 2019 at 9:25 am #4602961

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have tried once again in the test installation and got the following results.

1) Translated Images are showing in the secondary language in Media>>Library section - hidden link

2) Translated Image is not showing for Product featured image in the edit screen. But it shows for gallery images of Product - hidden link

3) On the frontend, the translated Product is not showing translation for Product featured image. But the translation is showing for the Product Gallery images - hidden link & hidden link

Please check once again and let me know you are getting similar results or not.

--
Thanks!

Bigul

September 20, 2019 at 3:19 am #4609137
nikolajW

Yes, I got the same results.

But we should look at the 3 options, how media content can be translated.

OPTION 1: User keep the same product images.
OPTION 2: User duplicate the Images
OPTION 3: User keep the same product images, while translating and than translate in WPML->Media Translation

For all options I made screenshots.

And I'm still not sure, why some of images in the media library not showing up like expected.
This should be clarified.

And another thing I discovered is, that if I use the plugin woocommerce subscription, the "Synchronise renewals" option is not enabled in the translated product version.

Regards

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/the-synchronise-renewals-option-is-not-enabled/

September 20, 2019 at 5:30 pm #4613903

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have shared the details with our second-tier team for the expert opinion and waiting for their feedback now. We will get back to you as soon as possible.

Please note, I have opened a new ticket for the Synchronise renewals issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. I will get back to you soon on the new ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul

September 21, 2019 at 8:36 am #4615587

nikolajW

Perfect! 🙂
Thank you very much.

September 25, 2019 at 1:17 pm #4639065

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, the issue existing after the initial debugging procedures. Therefore escalating the ticket to our developers for further debugging.

As a workaround, for the time being, please enable *Duplicate media attachments for translations* and *Duplicate featured images for translations* options for the Products from the Edit screen. It will help you show the translated images in translated Products. Including the featured image and gallery images.

Please check the following Product of the test site for more details.

Deafult Language Product:- hidden link

Translated Product:- hidden link

Translated Product's Edit Link:- hidden link

--
Thanks!

Bigul

September 25, 2019 at 1:55 pm #4639539

nikolajW

Ok, I guess this ticket maintains open until this issue is resolved?

Is it possible to estimate very roughly a time, by the developers experience?

Regards

September 25, 2019 at 2:26 pm #4639897

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. The ticket will be open until the issue is resolved. Right now we don't have the exact time frame required for the fix. I will get back to you as soon as possible when we have an update from the developers on this. Please wait.

--
Thanks!

Bigul