This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Radu 1 month ago.

Assigned support staff: Radu.

Author Posts
September 1, 2019 at 12:56 am #4491675

taimurM

Hi ! The product featured image on translated version not showing on single product page

Specially the Product Image had gallery images in it

As per screen shot the product have single image is fine but the product with multi images not displaying

September 1, 2019 at 2:03 pm #4492597

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Could you edit the original product and make sure that the Duplicate uploaded media to translations and Duplicate featured image to translations options from the right sidebar are checked, please? If they are not already, just check the two boxes, and hit the Update button. Once you did this, please check again the translated product, and tell me if the images are still missing.

Thank you,
Radu

September 2, 2019 at 2:30 pm #4497661

taimurM

Before coming to this Issue you need to help me on other ticker I dropped then we'll be coming here

September 2, 2019 at 3:29 pm #4498297

taimurM

Well I have resolve my other issue which products was not showing on home page now they are up - but I need to resolve this issue on urgent basis - Product featured image not showing with multiple product issue

September 3, 2019 at 5:43 am #4501379

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Can you tell me if you tried to do the little change I suggested on my previous reply, and see if there's any change? That option should be the one to make the images appear on the translated product.

Thanks,
Radu

September 3, 2019 at 8:03 am #4501819

taimurM

Yes I do tried images are duplicated if ther aren't they wouldn't have been shown in Home page

September 4, 2019 at 7:45 am #4508835

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Can you go to Dashboard → WPML → Settings → Media Translation, make sure that the first three boxes are checked, and then press the Start button, please? Once the process ends, check again the product images.

If the issue is still there, please give me access to the dashboard area and I'll have a closer look at this issue. I'm sure we'll be able to sort things out.

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

September 5, 2019 at 6:44 am #4515713

taimurM

First option is grayed out how can I Check this option

September 5, 2019 at 7:16 am #4516049

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

It is fine that the option Set language information for existing media is greyed out. It is like this in most of the cases, and it means that you do not need to take any action regarding this option and the existing media already has the language information.

Thanks,
Radu

September 5, 2019 at 11:09 am #4518651

taimurM

OK on another ticker I shared my details so sync it from their and please go through the issue

September 8, 2019 at 10:54 pm #4532609

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Once you check the two options I early mentioned (Duplicate uploaded media to translations and Duplicate featured image to translations) and hit the Update button, please redeliver the translation by editing it and pressing the Finish button. This way, the changes will be added to the translated product and images will appear very well.

I tried to do this for the Curren Casual Watch For Men Analog Stainless Steel - M8230 and, as you can see here hidden link, the image is showing well now.

Thanks,
Radu

September 9, 2019 at 3:14 pm #4538473

taimurM

Hello Radu ! The product with single image (Featured Image) is showing in arabic Version but pictures with Gallery is not showing in Arabic Version

September 10, 2019 at 11:04 am #4544385

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I checked this product hidden link and it seems that it doesn't have a gallery in English either. This means that it won't have a gallery in Arabic either.

Can you send me a link to a product that has a gallery of images in English but not in Arabic and the issue is still there even if you check the Duplicate featured image to translations and Duplicate uploaded media to translations options, please?

Thanks,
Radu

The topic ‘[Closed] Product Image not showing in translated version’ is closed to new replies.