This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Product images are not show in the translated product (woocommerce)
In the Settings (Media Translation) is synced, but images are only showing in the default language

Solution: The WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section

Relevant Documentation: https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

This topic contains 2 replies, has 2 voices.

Last updated by guentherJ 3 months ago.

Assigned support staff: Laura.

Author Posts
July 14, 2019 at 3:30 pm #4205779

guentherJ

Hy My Product images are not show in the translated product (woocommerce)
In the Settings (Media Translation) is syced, but images are only showing in german. any idea what to do ?

July 15, 2019 at 8:15 am #4208173

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

The WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

Once you've done this, please try updating one of the original products, and after, its translation. When updating the translation, make sure it has the circular icon with 2 arrows, not the pencil one. If after saving the translation, you can see the image in the English version, you can bulk update all the products and the issue should be solved.

July 18, 2019 at 3:56 am #4234917

guentherJ

My issue is resolved now. Thank you!