This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: the client needs to change slugs for product and product categories

Solution: To change single product slugs: - go to WPML -> Settings -> Translated documents options -> check "Translate (this will include the slug in the translation and not create it automatically from the title)" - open the Classic Translation Editor or Advanced Translation Editor and you'll find a line where you can change the slug - for Manual Translation, the option to edit the slug is right under the title

To change base product slugs: - go WooCommerce -> WooCommerce Multilingual -> Store URLs OR Settings -> Permalinks - resave Permalinks in Settings -> Permalinks

This topic contains 11 replies, has 2 voices.

Last updated by mathiasS-12 12 months ago.

Assigned support staff: Laura.

Author Posts
October 16, 2018 at 7:20 am

mathiasS-12

I am trying to: After translating the products from English to Danish, I am unable to change the Danish product links. Even if I change and save the new links in ATE they do not appear. I don´t have access to the Danish product links but only the English ones. I tried to save the permalinks again, but it didn´t change. What else can be done to fix the problem?

Link to a page where the issue can be seen:
One example
EN: hidden link
DE: hidden link

I expected to see:
Ideally the Danish links of the products should be changed.

The correct links should be:
Balcony base:
EN: hidden link
DK ok: hidden link
DK NOT OK: hidden link

Garden base:
EN: hidden link
DK ok: hidden link
DK NOT OK: hidden link

Multifunctional sandbag with handle
EN: hidden link
DK ok: hidden link
DK NOT OK: hidden link

Multifunctional sandbag without handle
EN: hidden link
DK ok: hidden link
DK NOT OK: hidden link

Instead, I got:
Even if I changed the Danish links they don´t appear, the old links are still active (see screenshots of one of the product)

October 17, 2018 at 3:45 pm #2825244

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

did you translate the base product? From your post, it's not clear.

You can translate them in Settings -> Permalinks or in WooCommerce -> WooCommerce Multilingual -> URL store tab

See also: https://wpml.org/documentation/getting-started-guide/translating-post-categories-and-custom-taxonomies/

You should also increase the WP Memory Limit. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

If these suggestions doesn't work, I'd ask for your site's credentials so I can take a better look.

October 18, 2018 at 8:20 am #2827152

mathiasS-12

Hello Laura,

Thank you for your message, we translated the products on the product page, so in each product, we translated it to danish. I tried changing the permalinks, I looked into the URL store tab but the result is not the one we are looking for. Our product links are structured like this hidden link, what we want to change is /garden-parasol-base/ in the Danish URLs. You can use these wordpress credentials:

[credential removed]

Concerning the Wp Memory limit, we are working on it. We have problems accessing the FTP or SFTP.

Thank you
Kim

October 18, 2018 at 5:45 pm #2829093

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I removed the credentials from your previous post because they were exposed in the public forum. Please don't add any private info unless we enable a private answer. As a further precaution, I'd suggest to change them.

I'm sorry for the misunderstanding, I thought it was a product category.
What you want to change is the product slug.
You can find it in the translation editor when you create or edit a new translation, it's the second row just below the title.

Let me know if this helps you or if you need further assistance.

October 22, 2018 at 6:46 am #2836912

mathiasS-12

Hello Laura,
I didn´t noticed that the tickets were automatically made public. I changed the password ?
Concerning the product slug (the link of the product), I found it in the translation editor (a couple of days ago) and changed it but it didn´t do anything. The old links are still present in Danish. Do you have an idea of what the problem can be?
Thanks,

Kim

October 22, 2018 at 1:38 pm #2838218

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi Kim,

did you resave the permalinks after changing the slugs? In Settings -> Permalinks.

You could also try to run the "translate link target" button in WPML -> Settings
(please do a backup before trying this)

Let me know if this helps you or if you need further assistance.

October 24, 2018 at 6:32 am #2845040

mathiasS-12

Hi Laura,

I tried resaving the permalinks after changing the slugs and also run the "translate link target" but nothing worked we still have the wrong product links in Danish. What else can we try out to fix this problem ?

Thanks

October 24, 2018 at 8:48 am #2845412

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

can you send the credentials again so I can better see?
I'll enable a private reply.

October 24, 2018 at 9:43 am
October 24, 2018 at 4:26 pm #2847277

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I resaved the product-base slug in WooCommerce -> WooCommerce Multilingual -> Shops and now it's correct.
About the product themselves, the slugs weren't changed, you need to save them.
Go to WooCommerce -> WooCommerce Multilingual and open the translation of your product.
See the image attached, the slug is the second row in Danish.
After you change it, you need to click on "save" or "save and close" at the bottom of the page.

I changed one slug for a test, as you can see it works perfectly now: hidden link

Let me know if this helps you or if you need further assistance.

October 25, 2018 at 8:30 am #2848997

mathiasS-12

Hi Laura,
That is great news that it can be fixed. But we don´t find the same elements you do.
- WooCommerce -> WooCommerce Multilingual -> Shops = We don´t have shop (see capture)
- Go to WooCommerce -> WooCommerce Multilingual and open the translation of your product = we end up in the translation of the product it self, it doesn´t look like your screenshot (see capture1)
Can you help us find the right place to change the links?
Thanks

October 25, 2018 at 10:03 am #2849386

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

sorry, the correct tab is Store URLs in WooCommerce Multilingual.

About the second screenshot, that is the Advanced Translation Editor. I cannot use it even if I logged in it, because I need authorization.

I enabled the option "Translate (this will include the slug in the translation and not create it automatically from the title)" in WPML -> Settings -> Translated documents options
so it should do the trick.
If it doesn't, we will investigate it, but in the meantime, you can enable the Classic Translation Editor in WPML -> Settings -> How to translate posts and pages just to translate the slugs and then come back to the Advanced Translation Editor.

October 25, 2018 at 1:04 pm #2849906

mathiasS-12

The instructions you gave us worked, are links are fixed now !! thanks