Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.99 hours from now. Thank you for your understanding.

This topic contains 4 replies, has 2 voices.

Last updated by Lauren 1 year, 11 months ago.

Assigned support staff: Lauren.

Author Posts
August 22, 2018 at 11:40 am #2666613

yunfeiS

I am trying to: After I changed the product permalink, my product couldn’t be showed out, it showed 404 not found.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

August 22, 2018 at 12:20 pm #2666747

yunfeiS

after I set Product permalinks to grocery-store-shop-china-wuhan-wh, the product’s link is that as below, I don’t think it works when there are two / in the link:
hidden link

August 22, 2018 at 5:35 pm #2667590

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

If you go to Settings -> General, is there a trailing slash on the end of your URL? If so, please try removing that and then resaving permalinks. Does this resolve the 404 page issue?

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

August 23, 2018 at 2:47 am #2668759

yunfeiS

No trailing slash on the end of the URL, other pages could be opened except the product page.
I already submitted the debug information.

August 23, 2018 at 2:42 pm #2670527

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please try switching your permalinks to default or post name. Does this change anything?

If not, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. With these settings, is the issue resolved?

The topic ‘[Closed] product permalink problem’ is closed to new replies.