This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by wojciechZ-5 1 year, 11 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 26, 2017 at 8:47 am #1412601

Manuel Lariño Torrens

I am trying to: set products as drafts in both languages

Link to a page where the issue can be seen:
product as draft in spanish, its published in english:
hidden link

I expected to see:
I expected that if a product is set as draft in the original language, the same state was set in the translated version.

Instead, I got: Instead, if I change the status of a product in the original language, nothing changes in the translated version.

October 26, 2017 at 4:52 pm #1413305

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support. I'll be happy to help you with this.

1.- I will consult this issue with my colleagues and I will get back to you as soon as I have an answer.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Please let me know if you need any further assistance and I will be happy to help.
Kind regards,
Carlos

October 26, 2017 at 5:22 pm #1413345

Manuel Lariño Torrens

Thanks
I just made that change to wp-config.php

I hope you can solve my problem soon.
thanks

October 26, 2017 at 5:34 pm #1413363

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Manuel,

The only way to change the status of the translated product is manually. There is a featured request created already about this subject.

This custom changes falls outside of our scope as support service. If you need to change the status of the product translation automatically I would recommend you to contact one of our certified partners in the following link: https://wpml.org/documentation/support/wpml-contractors/

Kind regards,
Carlos

October 26, 2017 at 6:12 pm #1413420

Manuel Lariño Torrens

The problem is that the plugin doesnt let me do it, because the edit screen is not of a normal product, is the editing screen that the plugin makes.

October 26, 2017 at 6:15 pm #1413428

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

In order to change this behavior you need to go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Product Translation Interface -> Set to 'Native WooCommerce product editing screen'

Regards,
Carlos

October 10, 2019 at 3:32 pm #4732317

wojciechZ-5

HI

I have same problem. I changed product for draft version in basic language but still see it in second language