Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by Norman 4 years, 3 months ago.

Assigned support staff: Dat Hoang.

Author Posts
July 13, 2015 at 4:55 pm #658227

krzysztofT-2

I am trying to set up custom product slug for various language versions. I've done the stuff from https://wpml.org/documentation/support/translating-woocommerce-sites-default-language-english/

In Settings -> Permalinks I have "/product" set as the product slug.

In WPML -> Translation management -> Multilingual Content Settings (or something like that, I'm using the Polish version of the admin panel) -> Custom Post Types under Products I have the following things:
- "Translate" selected
- "Use different slugs in different languages for Produkty" selected
- English (original) set to "product"
- all other translations set to "product", excluding German which I set to "produkt" for testing purposes

Under WPML -> String translation when searching for the "products" string (exact match selected) for the product URL slug I have settings as above (all but German set to "product", German set to "produkt") and selected all "Translation complete" boxes.

I've rescanned the strings multiple times, refreshed the permalinks multiple times.

For German, with these settings, WP generates proper product URLs at the main page: hidden link
These product URLs return a 404 not found, example: hidden link
It seems that WPML isn't loading the page properly. It works for the following URL: hidden link (with the options described above).

No matter what slug I set for any language other than English in WPML -> Translation management -> Multilingual Content Settings -> Custom Post Types -> Produkty, the URLs always work only for the "product" slug and not the one I set there.

The only idea I have for this issue is as follows: I had WPML 3.1.9.7 earlier and the site's default language in WPML settings set to Polish (NOT English). Then I manually updated all WPML plugins to WPML 3.2.2 and compatible ones. Then I noticed that WPML 3.2.2 has removed the option to change the site's default language, so I thought it's better to change it while I can. So I did click the button "apply the fix" under WPML -> WooCommerce Multilingual where it said that it will change the default language to English and re-scan the strings (which I did later on). Maybe this broke something. I'm not sure if the custom product slug worked before I made the switch to WPML 3.2.2, but it's the best idea I have. The issue might be somewhere else, however.

July 13, 2015 at 5:04 pm #658238

krzysztofT-2

Other things I've tried: WPML -> Support -> problem solving (or something like that) -> I clicked "Delete dead posts from translation tables", "Set language info", "Fix post type assignment for translations" (it said it fixed 1 thing) and refreshed the permalinks once again. No luck, the custom product slug still doesn't work.

July 14, 2015 at 7:32 am #658561

Dat Hoang

Your WPML versions are up-to-date (WPML 3.2.2 and its add-ons).

Thanks for your detailed info. Based on your info, I think you're setting correctly.

#1,
Go to wp-admin > Settings > Permalinks > Save these options.
Does that help?

#2,
If you disable all non-related WPML plugins - keep WooCommerce active, switch to one of default themes, the problem persists or not?

NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

July 14, 2015 at 1:20 pm #658978

krzysztofT-2

#1 - I refreshed the permalinks the way you mentioned multiple times, didn't help.

#2 - I have narrowed down the issue to the WPML Media plugin - when it's turned off, the products custom slugs work, but when turned back on, they give 404 not found.
I then went to WPML -> Media translation and hit the "Start" button and waited for the process to complete, but this didn't help. I'm still getting an error 404 not found for product slugs when the WPML Media plugin is activated. Any ideas? I will switch the product slug for German to "product" for now so that the site works, but the issue remains.

July 15, 2015 at 7:40 am #659471

Dat Hoang

#1 and #2,
Thanks for your info.
As far as I know, this problem should not be related to WPML Media.

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:
+ Backup (both files and database) your site before giving us your credentials
+ It would be better if you give me the test site rather than the live site.

July 16, 2015 at 4:16 am #660253

Dat Hoang

Thanks for your credentials. FTP is wrong while WordPress access is correct. If they are changed, you can update the previous private reply.

As I see you're configuring "product" for all languages, right?
In general, it should work if you translate them. I did not make any change to see what happens in reality if I change 'product'.

Can you please create a test cloned site and give me the access for testing and checking?
If not, please create a Duplicator snapshot and let us grab it, test it on our localhost?

-----------
For creating your testing site, please use Duplicator ( http://wordpress.org/plugins/duplicator/ )

Duplicator instruction
hidden link

NOTE:
+ wp-content/uploads folder is not necessary, you can exclude it in Create New > Step 1 > Section “Archive” > Files > Filter

August 3, 2015 at 3:02 pm #672313

Norman

Hi,

I have exactly the same problem.
Can you please tell me what was the problem?

The topic ‘[Closed] Product slug translation not working’ is closed to new replies.