This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
July 15, 2019 at 3:11 am

stevenB-5

I am trying to:
While using Woocommerce, when I make changes to a product in the primary language some attributes like stock quantity, product status (draft, published, etc) and in some cases prices are not getting updated on the translated product. I manually have to click on the translated product and re-save it. I have the latest version of WordPress and all the plugins also. My primary language is French and my secondary language is English. Pricing problems occur mostly on variable products. I created a backup version on a test site. You can make any changes to it to test it.

Link to a page where the issue can be seen:
Here is a video of the issue for the status. The stock quantity has the same problem. hidden link

I expected to see:
The stock and status of the translated product should update when I save the product in the primary language.

Instead, I got:
Status and stock quantity does not update when I save the page in the primary language. I need to open the translated page and click save again for it to update.

July 15, 2019 at 11:24 am #4210375

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

The debug information states that your site is using an older version of WPML 4.0.8.
I would request you update to the latest version of WPML and its Add on plugins including WooCommerce Multilingual.

The update can be done from Plugins > Add new > Commercial tab, In case if you have any errors, Please follow the steps mentioned in the ticket quick solution section => https://wpml.org/forums/topic/pclzip_err_bad_format-10-unable-to-find-end-of-central-dir-record-signatur/

Once updated, Update the product in the primary language and update the translation, If you have more numbers of product try the bulk edit option as mentioned in the below steps
- Goto Products > All Products
- Select the Default Language of your site from the top bar
- Select all the products, Select "Edit" in the Bulk Action section
- Don't change anything just hit the Update button
- Change the language to one of the translations from the top bar
- Repeat the same steps for the bulk update.

Please refer to the screencast for more clarity => : hidden link

I hope this helps you resolve the issue.

Kind Regards
Raja

July 15, 2019 at 1:22 pm #4211415

stevenB-5

Hi Raja,

thank you for your quick reply. I've updated all the plugins. It was strange that I didn't get the update notification on the plugins... After doing the steps you provided, the result is the same. Once I modify a product in the primary language (product status to draft for example), the translated product does not get updated, it's still marked as "published" and shows up in the website. Is there anything else that could be causing this?

July 16, 2019 at 7:39 am #4217181

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

The older version of WPML plugin had this update issue which was fixed in the later release,

Please try the below troubleshooting steps,
- Go to WooCommerce > WooCommerce Multilingual > Settings, Click on the troubleshooting link located at Scroll down to the bottom of the tab
- in the troubleshooting page, select the below options and click start
x Sync products variations:
x Sync product stock quantity and status

Check if that resolves your issue.
If not, I might need to have a closer look into the issue, The access you have provided at the beginning of this thread is no longer valid, Please create temporary access to your site and share the details in the next reply which is marked as private for security purpose.

Kind regards
Raja

July 16, 2019 at 2:08 pm
July 17, 2019 at 8:01 am #4227015

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Glad that stock synchronization works,
Regarding the issue with status change, It is an expected and intentional behavior from WPML, The plugin doesn't synchronize the post status in translation when changed from published to draft.

Since this is a known and international issue Please check the resolved summary section of the below ticket (the yellow section at the top) for an alternative solution to set the post status of translations to draft.
https://wpml.org/forums/topic/post-status-not-updating-for-translations/

I hope this helps you better, Let me know if you need further assistance.

Kind regards
Raja