We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Product swatches images are not showing in translated French page + Ive chosen large option but the images are showing very small. (WooCommerce Variation Swatches and Photos plugin)

Solution: It's possible to fix this using the global attributes. Please try the following: - Go to Products > Attributes - Check if your attribute is displayed here. If so, click on "Configure Terms" - You should see the terms and swatches listed here. Click on "edit" to edit the term options - Check if the settings are ok for the term - Change the language using the language switcher at the top admin bar to edit the translation - You are now editing the translation of this term. Fill all settings like the original and save - Now the swatch related to this term should be available on this new language as well. Repeat the proccess with the other terms.

This topic contains 11 replies, has 2 voices.

Last updated by nathalieH-4 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
September 30, 2018 at 4:42 pm

nathalieH-4

I am trying to: Product swatches images are not showing in translated French page + Ive chosen large option but the images are showing very small.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got:

October 3, 2018 at 6:47 pm #2785488

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @nathalieh-4, welcome to the WPML support Forum!

Sorry for the big delay. We are with a large volume of support requests at the moment. this is not usual in our forum.

Please try the following:
- Go to the edit screen of the product (default language)
- Scroll down to Multilingual Content Setup
- Check if there is fields related to the images. If so, set them to Copy
- Click on Apply
- Do a small modification on the product description and click on Update
- Check if it fixed the issue

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

If it does not work, please try using the manual translator:
- Go to Woocommerce > Woocommerce Multilingual > Settings >
and set it to "Native WooCommerce product editing screen"
- Go to the edit screen of the product (default language)
- Change the language using the Language Switcher at the top admin bar
- Check all settings of the translation and fix it if needed

Please let me know if it worked for you.

All the best,
Diego

October 6, 2018 at 1:56 am #2791963

nathalieH-4

I still have the same issue

October 8, 2018 at 12:28 pm #2795973

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

In this case we need to isolate the issue in a new installation, so we can do some testing and check if it is a compatibility issue.

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the plugin to this test install and setup it the same way as in your website (using the same options). After that, please create some dummy content and check if the same issue occurs on this test website. Please note that we only need the plugin, some dummy content and the related functionality, you don't need to setup a entire website or clone your existing site.

Regards,
Diego

October 8, 2018 at 1:38 pm #2796156

nathalieH-4

hidden link

Ive created a dummy product and shut off all wpml plugin.

Which confirms me that the issue is probably with the theme and not WPML.

Let me know

October 8, 2018 at 9:07 pm #2797333

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks! I will run some tests and send you a feedback soon.

Kind regards,
Diego

October 9, 2018 at 3:27 pm #2800829

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks, I have reproduced the issue. THe images are not displaying on the translation:
- hidden link (original, works ok)
- hidden link

I have forwarded the details to our Themes > Plugins Compatibility Team and they will contact the author. Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

It would be great if you can also contact the author asking him to reply us. You could also refer them to our Go Global program so that we can help them make their product compatible with WPML: https://wpml.org/documentation/theme-compatibility/go-global-program/

This may help expedite the process.

Regards,
Diego

October 17, 2018 at 4:17 pm #2825317

nathalieH-4

Do you have any update?

October 18, 2018 at 1:32 pm #2828080

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

We're still working on it. I'll send you feedback soon.

Regards,
Diego

October 19, 2018 at 12:53 pm #2832036

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

It's possible to fix this using the global attributes. Please try the following:
- Go to Products > Attributes
- Check if your attribute is displayed here. If so, click on "Configure Terms"
- You should see the terms and swatches listed here. Click on "edit" to edit the term options
- Check if the settings are ok for the term
- Change the language using the language switcher at the top admin bar to edit the translation
- You are now editing the translation of this term. Fill all settings like the original and save
- Now the swatch related to this term should be available on this new language as well. Repeat the proccess with the other terms.

It works, you can check here:
- hidden link
- hidden link
- hidden link

Please note that the swatch type should be defined as "Taxonomy Colors and Images" on your product (see screenshot 4).

Please let me know if it worked for you.

Kind regards,
Diego

October 19, 2018 at 1:06 pm #2832152

nathalieH-4

Its still doesn't work in the French translated page

October 19, 2018 at 1:16 pm #2832190

nathalieH-4

My issue is resolved now. Thank you!