This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 3 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
June 17, 2019 at 12:41 pm #4035321

andreasL-23

Hi,

We have had an issue on hidden link, since launching the e-commerce (December 2018), with product titles randomly disappearing from the site. Two weeks ago I made updates to all our wpml-registred products, hoping it would solve the issue, however we have since then had multiple titles disappeared once again.

I've seen that there's a lot of threads regarding this topic, but none of them seems to have solved issue.

What can we do to get rid of this problem?

June 18, 2019 at 12:11 am #4039021

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

June 25, 2019 at 9:17 pm #4087267

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and couldn't reproduce the issue. Is there any specific product where the issue can be seen? In which languages the titles are disappearing? Does it disappearing in your website frontend only or both backend and frontend? Please, let me know these details, so we can proceed with further investigations. Have a nice day.

June 25, 2019 at 9:22 pm #4087297

andreasL-23

Hi Marcos,

We need to change back the names when this happens so at the moment there's no products where the name is missing.

They are disappearing both in english and swedish. They are disappearing on the backend (which, of course, makes them disappear on the frontend as well). When this happens, the product title field within WordPress turns empty and the product title is not shown anywhere (product page, products listing, order lists etc).

June 27, 2019 at 12:46 am #4095395

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. As the issue seems to be happening pretty randomly it is not so easy to figure out the cause here, I recommend you to enable the WP_DEBUG mode and take an eye on it when the issue happens and let me know if you see any suspect log message (see https://wpml.org/documentation/support/debugging-wpml/). Also pay attention if the issue happens after a certain event, such as plugin updates, products creation/update and so on. Please, let me know as soon as you have these details, have a nice day.