This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.07 hours from now. Thank you for your understanding.

This topic contains 8 replies, has 2 voices.

Last updated by Andreas W. 3 months ago.

Assigned support staff: Andreas W..

Author Posts
July 10, 2019 at 6:21 pm #4183687

danieleD-29

Hi
I use WPML whit WooCommerce on my site, I've also the WooCommerce Multilingual plugin
I create e custom product type
When I translate a product, it saved as simple product type and I can't change the type because it's locked
How can I solve the problem?

July 10, 2019 at 10:11 pm #4184645

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

While translating WooCommerce with WPML it is sadly not possible to edit the mentioned options for translated products. All product translations will in fact not create anew product, they are further a copy of their original product and have the same stock and price.

The workaround here would be to create independent product for the translated content. Go to Products and change the admin site language in the top admin bar. Now, add your product for the desired language.

Please take note that in this case a new product is created and there will not be anz link in regards to stock amount and the price of the original product.

Could you please explain a little further, what exactly you are trying to edit?

Kind regards
Andreas

July 11, 2019 at 8:52 am #4187633

danieleD-29

I create a product in Italian, whit product type "Custom", then I translate the product in english but when I publish the product is saved whit "Simple product" type
It is good that the translation is a copy of the original product, but should have the same type
This is the problem, the type is not the same, why?

July 11, 2019 at 3:03 pm #4191321

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

July 12, 2019 at 11:57 am #4198315

danieleD-29

I don't see he wp-admin/FTP fields

July 12, 2019 at 2:34 pm #4199811

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry about the inconvenience. I am sending the same request again.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

July 16, 2019 at 2:57 pm #4221433

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have logged into your site and revised your prodcuts but I did not find anz product that has a different product type than the original product.

I then created some test draft product and did not receive any issue while translating with the WPML Translation Editor.

It seems you are expereincing the issue when trying to translate manual, means using the WordPress product Editor, correct?

Would it not be more convenient for you to translate using the WPML Translation Editor and taking manual edits afterwards?

In order to enable the WPML Translation Editor please enable the option inside the Language settings on the right side of the product editor screen.

Also, please take not again that the settings seen on the screenshot attached to this message are not able to be edited for any translated product. In fact, WooCommerce Multilingual is currenlty not supporting manual translations as it would lead to issues if these settings would be different than on the original product. Meanwhile translating with the WPML Translation Editor assures that those settings stay synced on the affected products.

I hope this answered your question.

Kind regards
Andreas

July 17, 2019 at 3:29 pm #4231775

danieleD-29

now the error no longer appears...
did you solve it?

July 17, 2019 at 9:36 pm #4233597

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for letting me know. I am glad to hear that the issue seems solved.

As mentioned in my last message, I have logged into your site and revised your prodcuts but I did not find any product that has a different product type than the original product.

Also creating new products and translating them with the WPML Translation Editor did not show any issues.

In case the issue appears again please reach out to us again but take note that when translating WooCommerce porducts with WPML then it is mandatory to use the WPML Translation Editor and any product information will not be able to be edited, as the translations are copies of the original product.

Kind regards
Andreas