Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Alejandro 1 month ago.

Assigned support staff: Alejandro.

Author Posts
October 20, 2021 at 6:06 am #9823403

herng-yueL

You can check the products here:

Example: hidden link

Product that have no variation because it is not sync: hidden link

How can I sync the variation together?

October 21, 2021 at 6:18 pm #9838743

herng-yueL

Pls help I still haven't receive any help for this issue

October 23, 2021 at 6:48 am #9848429

herng-yueL

Hello, can I get any help on this?

October 23, 2021 at 11:53 am #9849131

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

By default the variations should be synced but if you created the translation of a variation after the product was translated, you'll have to go to WooCommerce > WooCommerce Multilingual > Attributes > scroll down to the bottom of the page and click the synchronize button.

--------------
Another option would be to go to WPML > support > Troubleshooting > Sync taxonomies (select "products" from the dropdown menu)
--------------
You could also go to WooCommerce > WooCommerce Multilingual and then select "settings" and "troubleshooting" at the bottom of that page.

Run all the options mentioned on that page one by one.

--------------
Otherwise you can add a character to the original production, save it and then update the translation. this is the last resort in case the other options fail and it needs to be done once.

Let me know how it goes.

October 24, 2021 at 9:24 pm #9852411

herng-yueL

Hello, I have tried all the options, however, it is still not working, there are definitely some changes, but please take a look at this url: hidden link

and the translated url : hidden link

The variation is not sync, can you please check on this?

October 25, 2021 at 7:36 am #9854107

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

To continue, I'll need temporary access to your site.

I have just activated the appropriate boxes for the credential information i need from you. they are private so only you and i will be able to see them.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

October 25, 2021 at 7:40 am #9854125

herng-yueL

Do you need FTP Details as well? Because it is a live site, i am really not comfortable in providing details like that. Also, can you please hide all the link i sent above? didn't know it is visible for others

October 25, 2021 at 8:55 am #9854927

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

The links are not visible to others, only for us (you and WPML supporters), they are hidden by default to non "authors" or supporters in WPML, so don't worry 🙂

you can test this by accessing this ticket on incognito mode, without being logged in.

----------------------

About the FTP, i won't need it, only WordPress access and a reference product. i will clone it, set it as private and work with the cloned product, so i'm not going to touch anything that others will be able to see, don't worry 🙂

October 25, 2021 at 9:54 am #9855773

herng-yueL

By the way, I also have issue with the footer translation, it did not show up after i have translated all the strings. Please help with that as well

October 25, 2021 at 11:02 am #9856317

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

The problem here is that those attributes are LOCAL attributes, so you haven't really translated them.

set the attributes in Products > Attributes and then add them to the product. this way you'll be able to translate them in WooCommerce > WooCommerce Multilingual > attributes

and then add them to the product + translate/update the product.

that way you'll have the attributes synced and working in all the translations.

October 25, 2021 at 11:38 am #9856689
herng-yueL

Thanks i willl look into that, can you please help me check why the footer is not translated as well?

New threads created by Alejandro and linked to this one are listed below:

https://wpml.org/forums/topic/translate-footer-of-my-site/

October 25, 2021 at 11:42 am #9856727

herng-yueL

Also, for the attribute, all of my products have a different attributes, so normally I will just add them in as custom attributes without naming them/ etc, how can I do about that?

Here is the screenshot of where I add the attribute.

Capture.PNG
October 25, 2021 at 2:14 pm #9858205

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

i ran a few tests and found something out.

there's a section about prices in different currencies. that feature might be the one creating the problem since "auto" might work in the original language but if the plugin is not compatible with WPML it will probably not mean anything in the translated languages.

would you mind disabling it for a moment or using our multicurrency feature instead? --> hidden link

--------------------

Another thing that might be a problem here is that there are things to do in Hindi, as seen in WooCommerce > WooCommerce Multilingual > Status: hidden link

--------------------

Last but not least, please flush and disable litespeed cache and your server-side cache (you can ask your hosting about it) while we keep troubleshooting this issue.

Regards.

October 25, 2021 at 2:30 pm #9858275

herng-yueL

The plugin is developed by Aelia, we do have a few of the plugins integrated with it so we can't really disable it. Any chance we can work around this? The site is live as well, I am unable to do any changes that might affect the user that is purchasing currently.

---

For the slugs, I have added Indian translation but it appears that nothing has changed.

---
For cache, we do flush every time we make changes and it still exists. Unfortunately, I am unable to turn off them at the live site as well, as it will cause the site to load very slow for user and leave them a very bad image of the checkout experience.

October 26, 2021 at 7:46 am #9862273

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Indeed you should not make any changes on the live site. could you please create a staging site so we can test there?

if you can't, we can create one for you in our servers, so you can clone your site, we can test it out and then, when we have a solution you can add it to your live site without any risk on your end.

Please let us know how you'd like to proceed so can i understand what to do next.

The topic ‘[Closed] Product Variation not synced’ is closed to new replies.