If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by lorenzoP-2 1 year ago.

Assigned support staff: Yvette.

Author Posts
October 9, 2018 at 4:29 pm

lorenzoP-2

I insert products in shop in Italian, after that I send them to Advanced WPML and everything work fine.

But in the english version in Variation switches doesn't appear images.
In some products also the main image disappear.

See screenshot.

I already tried the Troubleshooting but doesn't work. PHP Limit is 256M.

October 10, 2018 at 8:58 am #2803499

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

This is because the attribute is missing the image in the 2nd language. (see images)

Please attach images to the relevant color attributes in EN language.

This shoudl resolve the issue.

October 10, 2018 at 1:36 pm #2804471

lorenzoP-2

Thanks.
Shouldn't WPML do this automatically?
And about main image, the problem is the same, I think. Why happened?

Why in Troubleshooting if I run procedure nothing changes and it find again problems?

October 10, 2018 at 1:44 pm #2804504

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

1. Taxonomy Meta data
You wrote: "...Shouldn't WPML do this automatically?.."
My understanding is that this is a known issue that will be resolved perhaps in the next release. In general, we are finding that taxonomy "meta-data" is not currently being caught by the translation tool.

2. Product Thumbnail
For the main image - if it is the Product thumbnail, this should happen if you have completed the Media translation setup here:
WPML -> Settings -> Media Translation -> Start
--and--
you have set all new media to be duplicated (all the settings below the "Start" button.

3. Troublehshooting
You wrote: "if I run procedure nothing changes and it find again problems"
I am not clear on what you mean by this statement. What procedures did you run and what problems did it find again?

Thanks for the clarifications

October 15, 2018 at 4:53 pm #2818370

lorenzoP-2

3. Troublehshooting
You wrote: "if I run procedure nothing changes and it find again problems"
I am not clear on what you mean by this statement. What procedures did you run and what problems did it find again?

Since I don't need to translate media, I don't use Media Plugin. I tried troubleshooting to resolve main image problem (in english version doesn't appear the main image, I have to edit manually every product using WordPress editor, not the WPML one), but finally I solved made everything manually...

October 16, 2018 at 7:38 am #2819955

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Thanks for the explanation.
You are correct that the troubleshooting tools would not help you out in this situation.

Just to clarify, even if you do not use the Media Translation plugin, you still **must** execute the media duplication steps as described in Step 2 of my previous message. The media must be duplicated to all language spaces and this functionality is now part of the core CMS product.

If there are no other questions we can close this ticket now as I understand you have resolved the original issue.

October 22, 2018 at 2:37 pm #2838456

lorenzoP-2

Thank you!