Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Product variations not showed in secondary language.

Solution: Go to WPML -> Translation Management -> Multilingual Content Setup -> Post Type Translations -> Set Products to 'Translatable - use translation if available or fallback to default language' -> Save changes

Relevant Documentation:

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 2 years, 6 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
March 8, 2018 at 11:46 am

peterC-12

Since one of the last updates of wpml and woocommerce, my product variations don't work anymore. It used to work perfectly.

I have 3 products and each product has 4 variations (one attribute 'material' with 4 options). Each of these 3 products is available in 3 languages.
But recently the attribute selection on the single product pages works erratically. In most of the languages, the attribute dropdown list is empty, sometimes it does not show at all.

hidden link
hidden link
hidden link

=> if you switch to other languages, you'll notice what I mean.

I have tried all the proposed solutions from the forum:
0) Changed the theme to Twenty Fifteen and Twenty Seventeen
1) the WPML troubleshooting page (clearing cache, synchronizing, ...)
2) the Woocommerce Multilingual page - 'attributes' tab (sync attributes and update variations)
3) the Woocommerce Multilingual page - setting tab - troubleshooting page (sync product variations, all the checkboxes) => all are done, but the "copy terms (select attribute)" part does not work, it keeps on spinning.
4) Deactivate and reactivate all the WPML and Woocom Multilingual plugins

None of these suggestions seem to have solved my problem.

Any other suggestions?

March 8, 2018 at 6:52 pm #1541050

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
Thank you for contacting WPML support.

I would like to ask your authorization to make a copy of the site in order to make further tests on a local environment withouth affecting the live site.

Looking forward to your answer.
Kind regards,
Carlos

March 8, 2018 at 7:08 pm #1541066

peterC-12

Yes, of course you can. I added the link to a zip archive with the duplicator files when I introduced this support issue a few hours ago. Alternatively, you can make a new duplicator file if you like. You have all the credentials.

March 8, 2018 at 7:16 pm #1541073

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,

Thank you very much. I will start by downloading the copy you shared already.

I will try to reproduce the issue on a local environment and isolate its cause. I will get back to you as soon as I have an answer.

Kind regards,
Carlos

March 9, 2018 at 5:26 am #1541367

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Peter,

I followed this steps:
- Deactivated all plugins except:
-- Advanced Custom Fields Multilingual.
-- Kadence Toolkit.
-- WooCommerce
-- WooCommerce Multilingual
-- WPML CMS Nav
-- WPML Media
-- WPML Multilingual CMS
-- WPML Sticky Links
-- WPML String Translation
-- WPML Translation Management

- Then I went to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link -> Selected the last 2 options and clicked on Start button.

After this steps the products and variations are shown correctly.

I would like to ask you to follow the steps above and once you finished, start activating the plugins one by one until you discover the one that is causing the issue.

Note: Remember to create a full backup of the site before making any change. This is for security reasons.

Please let me know the result of this steps.

Kind regards,
Carlos

March 9, 2018 at 3:18 pm #1541920

peterC-12

Hello Carlos,

I did exactly what you proposed. But -as mentioned in my initial description- it hangs ( = it keeps on spinning and never completes that task). You can try it for yourself on my live website. You have the credentials.

Best regards

Peter

March 9, 2018 at 6:57 pm #1542137

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Peter,

I made all the changes, including going to WPML -> Translation Management -> Multilingual Content Setup -> Post Type Translations -> Set Products to 'Translatable - use translation if available or fallback to default language'

Could you confirm that the issue is solved?

Regards,
Carlos

March 10, 2018 at 10:09 am #1542437

peterC-12

OK. Now it seems to be working. Thanks!
Strangely enough, something unrelated happened in the process: I lost some footer menu items. But I guess I'll get those back on my own.

March 10, 2018 at 5:25 pm #1542539

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Peter,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos