This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Alejandro 5 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
April 17, 2019 at 10:26 am #3629607

giorgioA-4

HI, I NOTICED THAT THE PRODUCTS ARE NOT IN SYNC BETWEEN TRANSLATIONS

PRODUCTS OK hidden link

PRODUCT NOT OK hidden link

HOW CAN I FIX THIS?

THANK YOU

April 17, 2019 at 10:33 am #3629685

giorgioA-4

HI, I HAVE TO RECEIVED A REPLY FOR THIS TICKET https://wpml.org/forums/topic/products-dont-sync-between-languages/ AND THE TICKET IS CLOSED. HOW CAN I FIX THE ISSUE? THANKS

April 17, 2019 at 11:26 am #3630133

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I am reassigning this ticket to Alejandro who attended your chat, He will continue to help you with the issue.

It seems your login details are removed due to security reasons, I would request you to please share the details again. I have enabled the private fields for you to securely share the details.

Kind regards
Raja

April 17, 2019 at 1:10 pm #3631059

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, could you please flush your site's cache and disable the cache plugin if possible?

if you also have Server-side cache (which i believe you should if you use litespeed) then please flush it and disable it as well too.

Let me know what you did because before the chat went offline, i had checked with our developers and made a few tests and the product element is compatible and should work.

Please let me know how it goes so i can access again and run further tests.

April 17, 2019 at 1:11 pm #3631065

giorgioA-4

HI, HOW SHOULD I DO THAT?

April 18, 2019 at 8:30 am #3637359

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

You can do that by:

1) Finding LS Cache and flushing your cache (the option is sometimes called "Clear Cache" or "erased cache" )

2) After you clear it, disable the LS cache plugin

LS cache should be also part of your server, so they should have a different type of cache on the server itself, you can ask your hosting support to clear it and disable it for the time being.

I'm asking you to clear and disable it because cache helps us have fast websites but they do so by showing "old versions" of the site, and it's harder to spot what has really been done by us because some changes really don't go through and they are not visible until days or even months.

Let me know how it goes so i can continue.

April 18, 2019 at 9:17 am #3637583

giorgioA-4

HI, WHICH OPTION SHOULD I USE?

PLEASE SEE ATTACHED.

April 18, 2019 at 9:38 am #3637813

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

You can erase the ones with the red X on the screenshot attached below.

April 18, 2019 at 9:43 am #3637851

giorgioA-4

OK.

IN WHICH ORDER?

April 18, 2019 at 10:12 am #3638041

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

That shouldn't really matter, but try to do them from first to last (following the order of the buttons)

Regards.

April 18, 2019 at 10:16 am #3638119

giorgioA-4

OK.

CLEARED CACHE AND DEACTIVATED PLUGIN.

WHATS NEXT?

THANK YOU

April 19, 2019 at 1:55 pm #3646213

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I found the problem and i believe we're dealing with a bug.

However, i was able to find a workaround in case you're in a hurry..

I explain everything that's happening and walk you through the workaround i just mentioned:
hidden link

What i explain is basically what's explained in this documentation: https://wpml.org/faq/how-to-link-already-translated-pages/

I'll notify you as soon as the proper fix has been made and has been released.

Regards.

April 23, 2019 at 4:55 pm #3666381

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

The compatibility team told me that this is not really a bug and it's the way the plugin has been designed to work with this shortcode, so you'll have to change the source language of this page as shown in my last reply, in order to make it work.

Regards.