Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I get the classic translation editor instead of the Advanced translation editor when trying to translate an already completed translation.

Solution: - Cancel the current job in WPML > Translation Management > Translation Jobs. (click the red x if it's a non-finished job)

- Go to WPML > Settings > How to translate posts and pages > Sync translators and translation managers

- Now go to the product in question and make a change to a native WordPress field like the title. save it

- Try to open the translation now.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by paulT-34 1 month, 1 week ago.

Assigned support staff: Alejandro.

Author Posts
January 13, 2021 at 9:20 pm #7839165

paulT-34

Clicking on one product's edit button brings up different (translated) copy of the page instead of the Automatic Translation Editor like the other products do.

January 14, 2021 at 9:39 am #7841917

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi there!

Please try the following:

1) Go to WPML > Translation Management > Translation Jobs. Cancel the job of the page if it's available (it will have a red X if it's active.)

2) Make sure you(the translator) are both a translator and a translation manager

3) Now go to WPML > Settings > How to translate posts and pages > Click the "synchronise translators and translation managers" button (right next to the advanced translation editor)

4) Last but not least return to the page in question and then make an update to it (like adding a character to the title. it needs to be on a WordPress native field like the title or the body fields.)

5) You can try to translate again and see if you can see the translation editor now.

See, what you are experiencing is usually a sign of a completed Job (wouldn't exist anyore so it can't open it) or a lost sync between the ATE server and your site.

Regards.

January 14, 2021 at 2:49 pm #7845793

paulT-34

Thank you for your help. I followed your instructions.

When I click on the pencil (edit) button on the WooCommerce Multilingual page I am taken to the ATE page. 🙂
When I click on the pencil (edit) button on the Products page I am taken to the edit page for the translated copy of the product.

I am fine with using the WooCommerce Multilingual page but only 3 products show up on the list and one of those is a translated product (translated copies show up on the Products page as well).

How do I get all my products to show up on the WooCommerce Multilingual page?

I believe there should be approximately 80 but the Products page shows 164. Did I create duplicate pages by using the edit button on the Products page?

January 14, 2021 at 4:00 pm #7846513

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

1) I believe the reason why you can't access the translation editor if you click the pencil icon with WooCommerce was a bug that was fixed in the latest release as you can see here: https://wpml.org/download/woocommerce-multilingual/?section=changelog

Fixed the link to edit translations in WooCommerce Translation Editor.

I'd suggest that you do a backup of your site or, better yet, create a staging site and test the new WooCommerce Multilingual Version.

2) ❌ Before proceeding please make a full website backup! ❌

By default, you should be able to see all the products in WooCommerce > WooCommerce Multilingual. so there might be something going on with the products.

Please try to go to WPML -> Support -> Troubleshooting
Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix post type assignment for translations"

3) Then, go to WooCommerce > WooCommerce Multilingual > Settings > troubleshooting
run all the options here (if it gets stuck, try running only one at a time)

4) Last but not least check if you have something to do in WooCommerce > WooCommerce Multilingual > Status.

Let me know how it goes.

January 18, 2021 at 10:47 pm #7873259

paulT-34

I have done all the steps in your message - twice.

Now I see page after page of products on the WooCommerce Multilingual page, and I don't seem to be able to filter the page so I only see the original English products.

January 19, 2021 at 7:10 am #7874935

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

To continue, I'll need temporary access to your site.

I have just activated the appropriate boxes for the credential information i need from you. they are private so only you and i will be able to see them.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

January 19, 2021 at 3:25 pm #7879167

paulT-34

I need an email address for you in order to create a WordPress user.

January 20, 2021 at 10:16 am #7885315

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

can you please check the password? it says the one you gave me is not correct

January 20, 2021 at 1:23 pm #7887665

paulT-34

Please try again. I just tested those credentials.
The password I gave you must not have been saved by WordPress.

January 20, 2021 at 4:15 pm #7889485

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Please check this video: hidden link

The problem was that the job had already been completed so it couldn't be opened but at the same time it probably lost sync with the Advanced Translation editor.

- To fix this you would have to cancel the current job in WPML > Translation Management > Translation Jobs. (click the red x if it's a non-finished job)

- Go to WPML > Settings > How to translate posts and pages > Sync translators and translation managers

- Now go to the product in question and make a change to a native WordPress field like the title. save it

- Try to open the translation now.

That should do it.

January 20, 2021 at 5:13 pm #7890173

paulT-34

Thank you for providing such a complete explanation in the video!
I will give it a try and let you know how it works.
Thanks again.

January 20, 2021 at 8:42 pm #7891679

paulT-34

I tried to do the steps you outlined but I couldn't find any non-finished jobs.

I am still seeing many products on the WooCommerce Multi-lingual page.
hidden link

Is this correct? If not, how do I get rid of all the duplicate products?

January 21, 2021 at 8:11 am #7894087

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

It's ok if there weren't non-finished videos, that means they were completed initially but they kept the old translation job so they need to get a "new one" that is not finished and that is done by updating the product itself (any WordPress field, try to avoid only WooCommerce fields because they are sometimes not taken as changes by WordPress so WPML won't really get a signal for translation updates).

About the products. there are 167 products showing in WooCommerce > WooCommerce Multilingual > Products

and the same quantity of products are also in products > All Products, which means that WooCommerce Multilingual is picking up the correct quantity of products.

However i do see that there are some products that are in russian, for example, but they are in the English language. this means that they were created in English directly instead of being created in Russian. they don't have any translation attached which means they are the "source" product.

- I'd recommend that you check this page: hidden link and send to the bin all the products that don't belong there, but don't delete them permanently just yet.

- Now, check your remaining products and check if they have the translations that you previously created for them.

With this procedure you'll do some cleaning and get the correct products in the correct places.

January 22, 2021 at 9:25 pm #7909103

paulT-34

It appears that everything is working now. Thank you!