This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.21 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by sjouked 6 months ago.

Assigned support staff: Lauren.

Author Posts
April 18, 2019 at 8:49 am

sjouked

Hi,

I don't want to translate all of my products, but do show them for all of the languages. I have removed all the translated categories.

Also see previous chat: https://wpml.org/forums/topic/products-not-in-categories-for-other-languages/

Have already checked that the products are set to fall back.

April 18, 2019 at 12:36 pm #3639167

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

The credentials provided are not allowing me to log in to your site. I have marked the next reply as private so that you can share the correct credentials. Thanks!

April 18, 2019 at 12:40 pm
April 18, 2019 at 3:37 pm #3640439

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks, I was able to access the site but I don't have access to the Tools option on the menu, so I couldn't test the migration for you. It may be that the migration is timing out due to the number of posts. Please ask your hosting provider to check the server logs to see if there are any time out errors. Also, enable debug lot to see if any php errors are shown there.

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

April 18, 2019 at 6:06 pm #3641393

sjouked

I have removed the hiding of the tools section. The migration tool was accesable as a pop-up in a lot of windows. I have enabled debug mode and php is also now displaying errors. However, there is no file in /wp-content/ with debugging information. At the time(s) I was starting the migration tool I can see timeout (504) to 'POST /wp-admin/admin-ajax.php'.

April 18, 2019 at 8:30 pm #3641793

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The credentials provided are no longer working for me. Please double check and update your previous reply as needed.

Also, please try the migration with minimal settings, meaning only WPML plugins and switch to a default theme such as Twenty Nineteen. You also may need to increase the max execution time. With these settings, then try these steps:
- enable the option for Language filtering for AJAX operations at WPML -> Languages
- clear WPML cache through WPML - > Support -> Troubleshooting -> Clear the cache in WPML

After these steps, see if you can run the migration again.

April 18, 2019 at 9:49 pm #3641927

sjouked

My issue is resolved now. Thank you!