Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Andrés 5 years, 4 months ago.

Assigned support staff: Andrés.

Author Posts
June 9, 2015 at 8:45 pm #635152

peterB-32

I am trying to:
Get all products to show up in both languages product category pages, however in the non-default language English products do not show up. When going to a Dutch (default language) product and then click on English you see the product just fine it only isn't visible on the product category pages.

How to workaround:
I was able to find a workaround for the problem but I am hoping there is better solution to the problem. When changing the slug for the English product and then changing the slug back to the original one everything appears to be working fine. Obviously this is a very time-consuming workaround and we are looking for a better solution.

URL of (my) website where problem appears:
Visible on: hidden link
Not visible on: hidden link

June 10, 2015 at 8:32 am #635385

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Peter,

Welcome to WPML support forum.

1. Could you please share with me a screenshot with your settings in Settings > Permalinks?

2. It would be good if you can provide me the WordPress debug.log (not WPML debug informations). Please check this page for instructions
https://wpml.org/documentation/support/debugging-wpml/
If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion)

I'll wait for your information.
Andrés

June 10, 2015 at 9:48 am #635461

peterB-32

Hi Andrés,

Thanks for getting back to me so quickly.

1) See attached.

2) http://pastebin.com/i62aczTJ

Thanks,

June 10, 2015 at 1:53 pm #635707

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I think this issue could come from how Product category base and Product tag base are defined. They should be remains as something like:
Product category base => "product-category"
Product tag bas => "product-tag"

And in Product permalink base > Custom Basis, you could use something like:
webshop/%product_cat%

Then, you should go to WPML String translation and translate those terms again.

Does it solve your problem?
Let me hear your feedback.

June 10, 2015 at 2:13 pm #635736

peterB-32

Will check this now. A new problem showed up as well, all categories (of both languages) are now displayed on the homepage (see screenshot)

June 10, 2015 at 2:20 pm #635742

peterB-32

It appears that only one language is active on the website right now, even though 2 are available in the back-end I cannot check whether the other issue is resolved until this one is taken care of.

Attached you can see both Dutch & English are set up in the dashboard.

June 10, 2015 at 2:45 pm #635770

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

*Important: Be sure to backup your site and database first before you proceed!
You can use a plugin for this if you like. You can use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

June 11, 2015 at 6:41 am #636054

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Thank you for this information.
Could you please:
1. Upgrade your WordPress version
2. Upgrade your Woocommerce plugin
3. Can you confirm that you have a complete backup of your site?

June 11, 2015 at 10:30 am #636284

peterB-32

Everything is up to date, I can confirm I have created a backup before providing you with login details.

June 11, 2015 at 1:07 pm #636404

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

It seemed like before installing WooCommerce Multilingual, you had changed the options for the taxonomy options for WooCommerce and set them. Everything looks to work normally now. You only need to translate your:
webshop, product-category and product URL's in String Translation.
Could you please confirm that everything is ok?

June 11, 2015 at 9:53 pm #636732

peterB-32

Thank you Andrés, it seems the website is now working again however the original problem of this thread + another problem that we discovered remain.

In the English version, not all products are visible:
Dutch (all products): hidden link
English (only products that had their slug changed manually): hidden link

The second problem I am talking about is that for English variable products, we are unable to select any options. Possibly this is because those options have not been translated yet, however I can't seem to find where we should translate these?

Example product with variable options:
hidden link

June 12, 2015 at 9:03 am #636952

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

After inspecting your database, I can see that your English products don't have any category associated with. I don't know if you have imported those products from qTranslate, or maybe it was associated to previous issue because categories weren't ready for translation, I really can't tell. But disabling WooCommerce multilingual editor interface from WooCommerce multilingual page, allows you to manually assign to those products their categories, once you do that, product reappears in English category page.

For your other issue, as the original issue is resolved may I kindly ask you please to open a new ticket for your new question? This will also help other users with similar problems find solutions when searching the forum.

June 15, 2015 at 2:17 pm #638633

peterB-32

Original issue resolved, will create separate topic

June 15, 2015 at 4:00 pm #638782

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I'm glad to hear it worked. Thanks for opening the new ticket.
Have a nice day.