This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.33 hours from now. Thank you for your understanding.

This topic contains 1 reply, has 2 voices.

Last updated by Bruno 1 year, 8 months ago.

Assigned support staff: Bruno.

Author Posts
October 25, 2018 at 9:43 am #2849300

claudiaS-18

I am trying to:

Have products display their translated text.

Link to a page where the issue can be seen:

I used WooCommerce Germanized, WPML and Divi. I only have two products, they are fully translated in the backend (see screenshots). Check this product for instance: hidden link (pass: #hp@18!)

I expected to see:

A fully translated product.

Instead, I got:

Weirdly, the product displays the translated short description, but the long description is still original language (German). I suspect it is related to Divi: short description is just entered in WooCommerce, long description is created in Divi.

October 26, 2018 at 2:32 pm #2853330

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

When I access your site, it looks like the content is translated correctly. I'll attach an image for you to see. Maybe it's a cache problem in your browser? Have you tried to access your site from another browser?

If the problem persists, can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

The topic ‘[Closed] Products not being translated’ is closed to new replies.