This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Diego Pereira 5 months ago.

Assigned support staff: Diego Pereira.

Author Posts
May 8, 2019 at 11:54 am

dennisB-21

I want to translate all the categories and products, to show them in both dutch and english.
The dutch already got set up, english came in later. When we translate the product, we can access it by the permalink (direct link), but when we go through the categories it's not visible.
The categories didn't show as well, but i found that when i translated the category and a product in it, it would show up, just not the products.
I've tried multiple solutions that i found (currency, sync taxanomies etc) but they are not working for me.
Is there something else i could look at?

May 8, 2019 at 1:27 pm #3767233

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @dennisb-21, welcome to the WPML support Forum!

Could you please check if the issue is related to the stock of the variations? Please go to Woocommerce >Products > Inventory and uncheck the "Hide out of stock items from the catalog" field. If you uncheck this option, the translated products are displayed?

Please let me know if it worked for you.

All the best,
Diego

May 9, 2019 at 8:08 am #3774003

dennisB-21

Hi Diego,
Thanks for your reply!
Sadly, this did not help. The option was already unchecked.
The 'weird' part tho, is that in the dutch (primary) language everything shows just fine, only in the english language it doesn't show up..

May 9, 2019 at 7:34 pm
May 9, 2019 at 7:34 pm #3779103

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I sent some instructions to replicate the website through a private message (previous answer).

Please let me know if it worked for you. If so, please send us clear instructions on how to see/reproduce the issue.

Kind regards,
Diego

May 10, 2019 at 8:56 am #3782431

dennisB-21

Hi Diego,

The migration is complete!
Thanks in advance

May 13, 2019 at 12:59 pm #3798427

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thank you. The migration worked.

The issue seems related to the WPML plugins that are not update. Could you please update WPML + All extensions on your website and check if the issue persist?

It worked on the test site: hidden link

Please let me know if it worked for you.

Kind regards,
Diego

May 14, 2019 at 9:30 am #3805181

dennisB-21

Hi Diego,

I was under the assumption i was up to date, apologies.
I updated everything to the latest version, but it still is not showing...
Also, i can't open the test site, it gives me an error: "Can't read dir of './bmyzruyhsz/' (errno: 24 - Too many open files)" and goes into an installation setup...
I'll try to look at it later today, and compare the versions and settings

May 14, 2019 at 5:47 pm #3809689

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Sorry, we are having problems today with database server and we are already working to resolve. That's whythe testing site is off the air.

I tried to access your website to check but could not access. a timeout error occurs (see screenshot). Could you please check? Please also install these plugins, so I will be able to take another copy of the website if needed:
Duplicator: https://wordpress.org/plugins/duplicator/
File Manager: https://wordpress.org/plugins/wp-file-manager/
All-in-one WP Migration hidden link

I remember having disabled some plugins. If possible, could you disable all plugins except WPML + extensions + Woocommerce and see if the issue continues?

Kind regards,
Diego

May 15, 2019 at 10:03 am #3814725

dennisB-21

Hi Diego,

Thats totally fine, i see you still have problems.
I made the website public, you should be able to log in there.
I have installed the plugins as well, in case you need more, feel free to install them (we have a backup, and the account has rights for it).

May 16, 2019 at 2:32 pm #3826911

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks you. I created a package with duplicator then installed a copy on my local server.

I did some tests and the issue seems related to the customizations of Woocommerce in your theme:
- If I switch to a default theme, the products are displayed as expected
- With your theme activated, If I temporarily move the customizations (woocommerce.php file and the woocommerce folder ) from your theme folder to a different location, the products are also displayed as expected (because it will load these files from the woocommerce plugin, instead of loading from your theme).

I did some tests to find a fix but unfortunately they not worked.

As this is a custom theme and customizations, unfortunately there is no much we can do. Please check our support policy here: https://wpml.org/purchase/support-policy/

In this case, I recommend to check the code of your theme related to woocommerce to see if it's updated If according to the latest recommendations of woocommerce (maybe some update has broken the template).

If you need, we have a list of experienced contractors available here: https://wpml.org/contractors/ - they have a lot of experience with WPML.

Kind regards,
Diego