Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Radu 10 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
January 14, 2019 at 10:40 am #3086831

sergeyS-14

After i use plugin wp all import, and plugin form WPML, i discover strange behavior

Some pages were translated earlier (and new imported) to Russian language shows white page...
No errors (wp_debug activated etc...), the page have 200 code (not 404 or 503 etc all fine...)
and this happend only in SOME of translated Russian pages... Not all pages... just some of them...

So i discover the way to fix this by go to english original content, and make translate by this way: (check the attached image) btw link of this is like so: hidden link

And after i save this without any changes (only hit SAVE button)! The url is works!

So i need is some one put me on direction of how i can programatycally make this translations in bulk...

For example, i can write the code where will be some action or hook to make same thing (re save translation) i show in image but for all my post_types i need.

I need to know possible hooks or action i need to use for it.

P.S. In troubleshooting page ive already try all possible buttons no one helps...

Thank you.

January 14, 2019 at 11:22 am #3087086

sergeyS-14

Forget to attach image

January 14, 2019 at 12:23 pm #3087319

sergeyS-14

Another strange thing with images... may be its related some how?

Is alwais appear "The WPML Media Translation setup is almost complete. Click here to finish the setup."

And when i click to finish setup i go this:

Look at attached image

January 14, 2019 at 2:03 pm #3087934

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Sergey,

Let’s try a few things that might get this fixed.

First of all, you can flush the permalinks by going to Dashboard → Settings → Permalinks. Here, just scroll down and hit the Save changes button.

If the issues is still there, please try the following steps:

  • Backup completely your site;
  • Go to Dashboard → WPML → Support;
  • Click on troubleshooting link;
  • Click on the Clear the cache in WPML button;
  • Click on the Remove ghost entries from the translation tables button;
  • Click on the Set language information button.

Please give a try to these two changes and tell me how things work after this.

January 14, 2019 at 4:41 pm #3088869

sergeyS-14

As i told you before i tried this already.

And of course i tried again but no luck...

I have created developer version of web site, i can give you an access so may be you will find the solution or at least point me to the right direction.

Thank you.

January 15, 2019 at 6:58 am #3091062

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Sergey,

There are a few more things that you can try.

First, something might’ve gone wrong with the import. This is why you should try to run the import one more time and see how things look now.

Another thing that you can try is to bulk edit the pages. In order to do this, follow these steps:

  • Go to Pages;
  • Select all the pages;
  • Select Edit option from the Bulk Actions dropdown (right at the top of the table, on the left side);
  • Press Apply;
  • Hit the Update button on the right side of the new area that appears.

This should work exactly like you initially asked but without using code. Repeat this set of steps for each language by clicking on the top bar language switcher.

Please let me know how things work this time.

January 15, 2019 at 9:45 am #3091834

sergeyS-14

I already try to reimport, and result is the same...

Thank you Radu, but this is not for Pages this is for Properties and its a custom post_type with a lot of taxonomy and metas this is will not work...

And this is why i ask to make bulk update from code, because its a lot of time to update it one by one...

Also if i update the Russian language like regular Edit, (as you can see in attached image) its not working.

Its working only if i update the post as i mention here https://wpml.org/forums/topic/programatically-update-all-translations-i-have/#post-3087086

Assume this warning:

"Warning: You are trying to edit a translation that is currently in the process of being added using WPML.

Please refer to the Translation Management dashboard for the exact status of this translation."

May be there is a way to mark all those posts like complete or done or something from there?

Because may be some how when it was imported it marked like not complete or not translated etc...

Or may be i can delete them from Translation Management dashboard or force set status as completed or whatever i can do with this...

January 15, 2019 at 1:23 pm #3093009

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Sergey,

I’m afraid that I cannot help you with the custom code that you’re looking for. This kind of service is outside of our support scope (since it might involve more than a few lines of code).

Have you tried to apply the previous steps to the Properties elements? Basically, this what you’ll need to do:

  • Go to Properties;
  • Select all the properties;
  • Select Edit option from the Bulk Actions dropdown (right at the top of the table, on the left side);
  • Press Apply;
  • Hit the Update button on the right side of the new area that appears.

Repeat this for every language by using the language switcher from the top admin bar. Just simply select a different language and start over from step 1.

Also, you please check on your development site and use the minimal environment. What I mean by this is use a default theme (like Twenty Nineteen) and only the WPML plugins (no other plugin). Once you set this up, just try to do the import once again and tell me how things work when doing this.

January 17, 2019 at 9:55 am #3101153

sergeyS-14

Thank you for advice's but Its still not working....

Because i discover the possible clue of the main problem can you tell me how i can debug the process of copy fields when some of custom posts are updated?

Please See the images and if you undesrand what i mean help me to debug (or may be fix some how?) the population of this field ("fave_property_images")

Thank you.

January 17, 2019 at 1:43 pm #3102223

sergeyS-14

Another thing i discover is some wrong related images or metadata of wpml in database because:

Look at this picture attached, i have only 28 attached images, but when i click edit translations its show me more images which is not related with this property... but wpml some how keep showing for me those extra images...

January 17, 2019 at 1:45 pm #3102249

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Sergey,

I think that this problem may be related to the theme you’re using but there’s a way to find out for sure what’s causing this problem. In order to see why is this custom field not translated when using the import option, I need to have a closer look at it. That’s why I prepared a sandbox for you. Please go to this link: hidden link.

First you’ll need to install the theme you’re suing (and all the required plugins, if any). Once you did that, import just a couple properties (five or so) and tell me if the problem with the custom field appears here too. Having this on a sandbox will help me check everything a bit closer and ask my dev colleagues have a look too.

Please note that we only need the theme and the related functionality, you don't need to setup a entire website or clone your existing site.

January 17, 2019 at 5:44 pm #3103318

sergeyS-14

Seems complicated... i need a lot of stuff.

But can i just set off the WPML Media plugin to check if the problem is there?

Or may be the problem appear because i was trying to run Media synchronize posts taxonomy in Troubleshooting page (but it never finished)?

January 18, 2019 at 7:58 am #3104956

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Sergey,

As you already mentioned, everything can be set back to normal only by updating each Properties item. I cannot help you with some code to do this change automatically because this might involve more than a few lines of code and it’s a job outside of our support scope.

In order to have a closer look at this situation and see what’s going on, I created a sandbox website. I know that it implies time but as you mentioned this situation may be caused by a custom field coming from your theme.

All you have to do is to:

  • install the same theme (including the plugins it may require);
  • make a CSV with only 5 properties for every language;
  • Import it as you did on your site.

You don’t have to create a copy of your website. Only a minimal environment is enough. I just need to see the problem and check different elements (settings, database values). If you could do this, I’ll proceed with checking it further.

The topic ‘[Closed] Programatically update all translations i have?’ is closed to new replies.