This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by johnC-37 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 3, 2019 at 2:35 pm #3735499


Tell us what you are trying to do?
- Use WPML Correctly

Is there any documentation that you are following?
- Your documentation is overwhelming. That's why I'm contacting you.

What is the link to your site?
hidden link


So the plugin works great, but I doubt I have it set up correctly.

I have created a site in English and duplicated all of the pages to enter French translations as provided by my client. I'm using a language switch in the menu and everything is working fine, however the plugin keeps giving me warnings I don't understand and which I ignore.

I want to update each page independently and don't need WPML to do any syncing for me. Neither do I need a third party translator, as all translations are supplied to me.

What settings should I be using in WPML > Settings and anywhere else within the plugin to achieve my goals of independent editing of both English and French pages.

Thank you

May 3, 2019 at 4:38 pm #3736931

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi John and thank you for contacting WPML Support!

I will be happy to help you with this.

I think what you are referring to is the notification/modal that is showing up after you open a duplicated translation. The notification that you see there is expected and it allows you to convert from a syncing translation to an independent one.

Here you can also find more about this functionality (I am also attaching a screenshot):

What you would need to do is click "Translate independently".

I hope that you will find this information helpful.

Please let me know.

Kind regards,
Mihai Apetrei

May 6, 2019 at 10:40 am #3747123


My issue is resolved now. Thank you!