Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to translate properties in WP Residence. I expected to see all property details as seen in the English version. Instead, I got only the featured image and other media.

Solution: If you want to duplicate a property, you can easily do that by following the steps presented in this article https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/.

This topic contains 19 replies, has 2 voices.

Last updated by Radu 1 month, 4 weeks ago.

Assigned support staff: Radu.

Author Posts
September 18, 2019 at 12:08 pm #4596223

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Peter,

I checked this out (and also worked again on my local website with WP Residence), and I could see that the main archive (hidden link) works fine, even if you change the language (hidden link). The translated property is shown very well.

I checked the pages you mentioned and I could see that they are created using WP Bakery. In this case, can you delete the translation of one of these pages, deactivate all the minify and caching options (as presented in my previous message), set to Off the Use WPML's Translation Editor option, and try again to create the translation, using the WP Bakery on the secondary language too, please?

I'm thinking that the translation of the module that controls the property is not created well, and that's why I'm suggesting creating it manually. Please give this a try and tell me how it works.

Thanks,
Radu

September 18, 2019 at 4:16 pm #4598819

peterA-35

Radu,
What you have just described is exactly what I did to create one Turkish property as a duplicate with no translation.
However I have just deleted this translation and gone through the whole procedure again exactly as you describe. No difference. So what I have is.
1. A duplicate property showing as being a Turkish property on the dashboard. Screen grab 1
2. A Turkish home page (Ana Safaya) showing no properties, there should be 1. Screen grab 2
3. Turkish Properties page (Gayrimenkul) showing none, there should be 1. screen grab 3
4. Turkish properties for sale page (emlak satisi) there should be 1. screen grab 4

So for some reason the Turkish pages described above are translated for their static information but are not picking up the links for translated properties. So nothing is showing.

I am now in an absolutely desperate situation and will have little choice soon but to scrap WP-Residence and WPML and start all over again. Alternatively give my client his money back and get my sanity back.

I am sure you are doing your best Radu and I thank you for that but this is the worst ever experience I have ever had with WordPress and I would be grateful if necessary if you could get more help to fix this.

Also I do not understand why I am having to turn off the SG Optimiser from my hosting service. It has never caused a problem with other WP sites before. I have followed your instruction but I have no idea why I am doing it.

Thank you and kind Regards,
Peter

September 20, 2019 at 11:28 am #4611713

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Peter,

I know that it can be a bit frustrating to translate all these elements but the theme has a specific way to work (the way that the properties or pages are created) and I'm still trying to understand how all the elements work in order to translate them.

I checked the secondary language homepage (hidden link) and I could see that the property from the Turkish language is showing fine now. Can you tell me if you made any changes to make it show. In the meantime, I'm looking at the text that's not showing as expected on this page, even it's translated.

Thanks,
Radu

September 20, 2019 at 2:09 pm #4612935

peterA-35

I eventually fixed the problem a couple of hours ago. The category or action needs to have the name and slug name the same. I have now successfully managed to get one translated property to show. I will proceed with the rest

Thanks

September 23, 2019 at 10:43 am #4622489

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Peter,

I'm glad to hear that you managed to sort this out. Well done!

I'll mark this ticket as resolved but if you have any other issue or question, please open a new ticket and we'll take care of it in no time.

Thanks,
Radu