Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Osama Mersal 2 months ago.

Assigned support staff: Osama Mersal.

Author Posts
December 18, 2020 at 4:28 pm #7695965

Bill Lafferty

I am trying to:
1. We started a project months ago to translated 80+ webpages.
2. We pseudo-translated the pages first to make sure translatable text was accessible in the xliff.
3. We uploaded completed translations into zh-hans.
4. But, some pseudo-translated still appears in the titles to image and text block elements. (Should say "Press Release" or "Download Resources", etc.)
5. Could you help us find it?

If you send me a private link, I will share login creds.

December 21, 2020 at 12:22 pm #7709405

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hello,

Thanks for contacting WPML forums support. I’ll be glad to help you today.

Could you please answer some questions to help me to understand the issue:
1- How did you do the translation that now keeps showing?
2- How did you eventually translate the site to Chinese?
3- Were the strings that now show the old test translation, also re-translated into Chinese?
4- What is the type of the string, is it a page builder element string, a theme element string, or a custom post type string?

Please allow me to remind you that we have dedicated support for translation services you could use.

Thank you for your cooperation.

Best regards,

December 21, 2020 at 9:21 pm #7712235

Bill Lafferty

Hi Osama,

1- How did you do the translation that now keeps showing?
Exported an xliff, pseudo-translated the content, and then imported the xliff back.

2- How did you eventually translate the site to Chinese?
After the pseudo-translation test in 1 above, translated the same xliff into Chinese, and then re-imported it.

3- Were the strings that now show the old test translation, also re-translated into Chinese?
Yes.

4- What is the type of the string, is it a page builder element string, a theme element string, or a custom post type string?
I believe it a string from a magic block.

Thanks for your assistance.
Bill

December 22, 2020 at 9:33 am #7714615

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi Bill,

Thanks for your answers. It helped me to understand your issue more.

Could you please confirm that the Magic Block you mentioned in your answer is this plugin (https://wordpress.org/plugins/magic-block/)?

If yes, I’m afraid that this plugin isn’t compatible with WPML and this plugin was not updated by its developer for over 11 months. So that might cause the issue you face.

But to make sure what causes the problem. would you kindly recreate the problem you’re having on this sandbox site? To do that kindly follow the following steps:
1- You could use this link to access the sandbox site hidden link
2- Install and activate the plugins that caused the issue
3- Make the same steps you have done before facing this issue
4- After that could you please tell me how the issue is reproduced?

As it is a compatibility issue so using this sandbox site will speed up the process.

Thank you for your cooperation

Best regards,
Osama

December 24, 2020 at 3:50 pm #7731381

Bill Lafferty

Hi Osama,

Thank you for the access to a sandbox. We'll replicate the environment and test it.

I'm going to be OOO till Jan. 4th, 2021. Please keep this ticket open until I return, and we can pick up from there.

Thanks!
Bill

December 24, 2020 at 4:26 pm #7731525

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi Bill,

Sure, I'll keep the ticket open. However, the sandbox site is being deleted after one week. But I’ll ask someone to prolong it for a month.

I hope you enjoy your vacation.

Best regards,
Osama

The topic ‘[Closed] Pseudo-translated strings hidden’ is closed to new replies.