This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by jelleT-2 5 months ago.

Assigned support staff: Laura.

Author Posts
May 3, 2019 at 10:10 pm #3738191

jelleT-2

First off, I couldn't publicise any translations of a page after the last update, however, after adjusting some settings the translation is automatically publicised after translating it in the classic translation editor.

The only problem I get now is that when saving the translation, it publicises and uses the wrong URL but it uses the English title in the accompanying text (see images).

Also, I was wondering if I could somehow edit the text that accompanies the publicised page.

May 4, 2019 at 10:08 am #3739809

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

I'm not sure I understand the issue. You are publishing translated post and pages, but when you share them on social media, they point to the default language?

What plugin are you using to share on social media?
Could you send me some links (on your site and on social media) so I can better check?

May 5, 2019 at 4:04 pm #3743425

jelleT-2

What I mean is that if I click on the button to create a translation (step 1), translate a post and save the translation (step 2), the translated post is published, while it also shares the post on Facebook and Twitter. However, it provides the link to the original post on hidden link, instead of the translated post on hidden link (the 2 other images).

The post is automatically shared by, I think, the jetpack plugin since I don't use any plugin to share posts.

As for the links:
Dutch website: hidden link
English website: hidden link
Facebook: hidden link
Twitter: hidden link

May 6, 2019 at 7:36 am #3745501

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I get the issue now, but do you want to share the right language link or you don't want to automatically share links when you publish a translation?

If it's the last case, you should check Jetpack settings and see if it's possible to disable auto-sharing because WPML can't interfere with a 3rd part plugin settings.

May 6, 2019 at 11:50 am #3748015

jelleT-2

I want to share the link to the right language and be able to change the accompanying message.

May 8, 2019 at 3:14 pm #3768337

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

sorry for the delay in replying but I'm asking for a second opinion.

May 10, 2019 at 2:41 pm #3785587

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

sorry for the huge delay but I tried to do multiple tests.

Regarding the links pointing to the wrong language, this is something we had sometime ago but apparently appeared again so I escalated it to the compatibility team.

About customizing the snippet instead, I see it's possible to do it if you are using the WordPress editor, not the Classic or the Advanced.
I need to investigate more but in the meanwhile you could use this as a workaround.

May 11, 2019 at 11:01 am #3790215

jelleT-2

That's ok.

I have to say that using the WordPress editor does publish and lead to the right link. The problem is that if I use that workaround, I can no longer publish a post, which is why I changed my settings to use the classic translation editor.

I want to show you that problem; however, I cannot change the settings back since I miss the manually create translations option in the new content section on the settings page.

May 11, 2019 at 3:19 pm #3790857

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

to come back to standard WordPress editor, open a post in your default language, you should see a switch in the right sidebar under "Languages" to disable the WPML editor. You can do it for the whole site if you want.
See this image, it's the green switch: hidden link

May 12, 2019 at 10:07 am #3792771

jelleT-2

Thanks, now when I publish a translation, then I get a publishing failed error. This also happens when I want to update a post and if I want to translate a page from English to Dutch unless I don't use a featured image.

So the only way I don't experience problems is by translating a post without a featured image from English to Dutch.

May 13, 2019 at 7:22 am #3795633

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

if there is an error, we need to understand exactly what it is.

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

May 13, 2019 at 6:51 pm #3801243

jelleT-2

Well, here are the last 50 lines of the log.

[13-May-2019 18:22:13 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:22:19 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:20 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:22:20 UTC] PHP Notice:  Undefined variable: estimated_time in /home/astron79/public_html/wp-content/plugins/post-reading-time-admin-panel/post-reading-time-admin-panel.php on line 93

[13-May-2019 18:22:21 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:21 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:23 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:22:23 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:23 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:22:24 UTC] PHP Notice:  Undefined index: prtap_postmeta_noncename in /home/astron79/public_html/wp-content/plugins/post-reading-time-admin-panel/post-reading-time-admin-panel.php on line 131

[13-May-2019 18:22:25 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:26 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:26 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:26 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:26 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:27 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:22:33 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:45 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:46 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:22:47 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:48 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:22:49 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:50 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:22:51 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:52 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:22:57 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:59 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:22:59 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:23:00 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:00 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:23:01 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:01 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:23:17 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:17 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:18 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:18 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:23:20 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:21 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:22 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:23:24 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:25 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:26 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:23:26 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:26 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:23:27 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:23:28 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:23:28 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103

[13-May-2019 18:24:21 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:24:26 UTC] PHP Notice:  Constant GDPR_VERSION already defined in /home/astron79/public_html/wp-content/plugins/wp-gdpr-core/wp-gdpr-core.php on line 28

[13-May-2019 18:24:26 UTC] PHP Notice:  Constant ICL_USE_MULTIPLE_DOMAIN_LOGIN already defined in /home/astron79/public_html/wp-config.php on line 103
May 14, 2019 at 8:49 am #3804883

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

could you report me what do you have in your wp_config.php file at line 103?

I'm not sure these messages are related to your issue.
Could you please explain step by step what you do before you get the message error in translations?

May 15, 2019 at 12:19 pm #3816361

jelleT-2

Line 103 says the following:

define('ICL_USE_MULTIPLE_DOMAIN_LOGIN', true);

What I do is start a new translation, translate the original content, then I take care of the tags and categories, I add the featured image which also doesn't work (the loading icon thing keeps rotating) after which I remove the image, and finally, I press the publish button.

May 16, 2019 at 9:25 am #3823745

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

we used this string a long time ago, and should be deprecated now. Which was the first WPML you used, and when you installed it?

I would suggest you take a backup and try to remove it from your wp_config.php file, to see if this changes something in the behavior you reported.

Also, please try to disable Jetpack and see if it's causing the issue.
If you still have it, check the browser console (see here if you don't know how to open it: hidden link) in the tab network/console to see if there are errors.
If you can't see any but you still have these issues, I'll take a copy of your site for testing.