This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by sabian1982 2 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
April 8, 2020 at 5:32 pm #5868541

sabian1982

Following on from the issue with articles not being set to draft (for French translation) my Spanish translator has finished translating the following article:

hidden link

I can't however find where to actually push the article so it publishes.

I've got to be honest WPML is starting to become a bit of a headache rather than a help as I'm clearly not grasping the seemingly rather complex usability design of this plugin.

Any help appreciated!

April 9, 2020 at 6:27 pm #5878831

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

If I understand correctly the translations are done from the Translation Service side and you just need to get them on your site now.

Please review the following documentation on how to pull the translations from within WPML Translation Management

https://wpml.org/documentation/translating-your-contents/professional-translation-via-wpml/#receiving-completed-translations

April 14, 2020 at 3:00 pm #5905641

sabian1982

I'm talking about translations that someone has done for me (rather than outsourced via your platform). As you can see, they are showing here... whilst in the WPML i have set document status to "Draft".

WPML > Settings > Translated documents options

1) how do i go about changing the articles from draft to published?
2) how can i view the translated content on the page without the entire WordPress backend changing to the French language

I was also going to ask:

3) how can i see the number of translated words from the original article/content submitted for translation

However i believe on the "Translation Dashboard" i simply need to check the relevant article and the word count will be tallied underneath.

April 14, 2020 at 8:41 pm #5908055

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

#1 I see, so you have it set as "Draft" under WPML > Settings > Translated documents options, if that is the case then you need to manually publish your articles.

A quick way to bulk publish is to go to Pages for example, select your pages-> From the dropdown select "Edit"->Then assign status "Published"

#2 Go to your User account->Edit->Language-> Change the Site Default to English or your desired language, this will prevent the backend language from changing

#3 That is correct a quick and easy way to do this is to go to WPML->Translatio Management and select your page/post/etc then at the bottom it will show you a word count. [screenshot]

April 14, 2020 at 9:55 pm #5908305

sabian1982

#1 actually the "draft" feature isn't working correctly on my WPML and content is being published immediately - I've reopened a debug request via this thread https://wpml.org/forums/topic/publishing-of-non-translated-content/

#2 do you mean within the main User profile within WordPress? In which case it's already set correctly on my profile (see screenshot). Given there is a bug with publishing translations when they should be set to draft, i wonder if my install has a bug in relation to this feature as well.

April 15, 2020 at 1:34 am #5908765

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I see, thank you for opening a new thread for that issue as it will most likely need to be reviewed by our developers.

Notice the option where it says "Set admin language as editing language"?

Uncheck that option and it should work

April 15, 2020 at 7:15 am #5910513

sabian1982

My issue is resolved now. Thank you!